MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Problems mit config.js

  • Hello,
    at first speciall thx for this project and your great Tutorial, that is also working for noobs like me. But unfortunately I have a problme with the config.js and the mirror ist not really starting. I have a pi 3 Model B.
    I allredy installed raspian freshly on the pi. Then I used your automatic installation with ssh. Installatoin worked completely . Then I installed pm2 - that worked, too. Now I could start the mirror with pm2 start mm . I became a black window with the Information, that the config file ist not there or not configured. But I allready changed the config.js.sample into config.js while doing sudo nano /MagicMirror/config/config.js.sample and saved this into config.js But the pi allready asks me for a working config.js File. Where is my mistake? Thx for support. Greatings from germany ;o) Hakupapa

  • Moderator

    Please post your config file here or paste it into to find any missing commas, brackets or similar things.

  • Here it is [0_1479420812149_config.js](Uploading 100%)

    I also tryed with the script - he wrote me that there is one undefined variable but I don´t know where it is.

  • I just started a new try from the beginning with new raspian and editing the config.js . It worked but now i have a problem with showing calender and rss news. It is just showing load. Here is my code:
    url: ‘
    url: “
    What is wrong?

  • so I tested new. It just needed a restart. Know Calender and News are working. But I have one more problem. Maybe here is somebody who can help?
    The MM ist not starting after reboot. I followed the tutorial with pm2 and I can start it with pm2 start manually. I also saved the like it is written on the tutorial:
    cd ~/MagicMirror
    DISPLAY=:0 npm start
    and I made the:
    chmod +x
    pm2 save
    but when I am rebooting I just came to the grafical desktop.

  • U must start the MM with pm2 start mm and after this u can exec the command pm2 save

  • thx for the fast answer. 🙂
    I have done this way (just forgot to write down). I got this information after saving:
    pi@raspberrypi:~ $ pm2 save
    [PM2] Saving current process list…
    [PM2] Successfully saved in /home/pi/.pm2/dump.pm2
    but after reeboting I just see the desktop

  • do u run the commands with sudo? if not, can you test it?

  • I tested all commands with sudo at the beginning. The same problem. Is it maybe because of the command for reebot (sudo shutdown -h 0)?

  • i don’t think so.

    please do this: pm2 start mm -> pm2 save -> pm2 Status -> pm2 save -> sudo reboot

Log in to reply