MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

updated installer script available for testing



  • Well that worked! Looks like Jesse is just too long in the tooth to run Magic Mirror2. Thanks again!



  • @BD0G cool. Thanks for the feedback. Could u post the the install.log to your Dropbox or email to me. Just want to look it over. Need to think about adding info about Jesse now.

    We need to update electron too (doesn’t work on pi 0 anymore, well armv6l devices)



  • I am having a heck of a time. I cannot use the local browser to visit my drop box site any longer as it directs me to localhost_/ and there is no web address bar to type the dropbox website into.



  • @BD0G chrome is being used for the mirror display, as electron no longer works with the later levels of node.

    I wouldn’t have expected another use to carry over the settings from the mirror task…

    pm2 stop 0
    

    then use chrome

    them

    pm2 start 0
    


  • Finally got it to work and upload to my dropbox. Stopping Magic Mirror worked and allowed the Chromium browser to access the drop box webpage, but using my standard credentials (which were correct) just timed out on the logon page. I tried this like 20 times. No dice. Finally logged into dropbox using my google account instead and that allowed me to access a dropbox account that I setup using google credentials.
    Ridiculous!

    Here is the link to the install.log
    https://www.dropbox.com/s/425lhitp7tcftih/install.log?dl=0

    Now on to the fun of making just simple syntax errors in the config.js file when configuring modules only to have Magic Mirror 2 complain that there is no config.js or an error. This process is 100 percent suck!



  • @BD0G cool, thanks…

    as for config

    each module is

    {
       module:   "name",
       position: "string",
       config : {
          something: "string",
          other_thing: number,
          another: true 
       }
    }
    

    not that each line has a trailing comma
    number/booleans don’t need quotes,
    everything else does

    single or double doesn’t matter, just have to match on a line

    if troubles
    do

    npm run config:check
    

    first 1st error, (usually reported on the line AFTER the error )
    rerun, etc



  • Thanks ! Thats the process I have been using . Painstaking. Small details always cause errors. Even if I cut and paste right from the github repository using the authors code.



  • @BD0G yeh, sometimes/many times they don’t check their doc …

    not THAT painstaking

    thing on the left of the colon doesn’t need quotes, only words on the right

    if something follows something else, the something else better have a trailing comma

    I may have found a better way to do the node/npm setup… testing now

    it allows node 10 on jesse…

    thanks for the trouble report so I could think about the problem



  • @sdetweil I entered this to LXTerminal. Whats the next step i need to do?



  • @magicmirrorpi4 u cut/paste the bash-------- )" string into the terminal and hit enter


Log in to reply