MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

How to go back to Pi homepage



  • Actually my friend has setup everything of magic mirror.
    And i want to customize some modules.
    But while connecting it through ssh, it shows connection failed error although pi and laptop both are connected with same network
    Also i am unable to go to pi homepage so that i can update anything from terminal of MM.
    Please help how can i give command to MM through SSH or directly on MM terminal.

    Thanks



  • @S2kushwaha

    alt-spacebar, n
    

    will minimize the MM app window… (just like on windows to minimize an app)…

    ssh server is not setup by default… so you would have to do that manually

    https://www.ionos.com/digitalguide/server/configuration/raspberry-pi-how-to-set-up-an-ssh-server/
    

  • Project Sponsor

    Another option is Ctrl+Alt+t which should open a terminal window. From there you can install the OpenSSH server, stop the Magic mirror process (pm2 stop all) or whatever.



  • @bhepler ctrl-alt-t won’t open a terminal window if MM is shown on the screen… that was his problem… he didn’t know how to get back to the desktop


  • Project Sponsor

    @sdetweil - Sure it will. If he can’t SSH into the Pi due to “connection failed error”, he has to be connecting directly to it and using the mirror’s screen. Ctrl+Alt+t will give him a terminal on the pi and he can then shut down the Magic Mirror process. Now that I think about it, he can also just run sudo raspi-config without shutting down the MM process, which should give him the option to install the SSH server.

    Now that I think about it, opening a terminal window may be hidden by the electron process. You can Alt+Tab to it, but it’s not something I included in my post. Hrm. I should do some experimenting.



  • @bhepler that’s why I said minimze the mm UI. Back to the desktop, then all works… Then put mm UI back on screen by selecting it from the Task bar or alt tab