MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

MMM-AssistantMk2 terminating and not activating by voice after that.

  • G’day to all.
    I am having issues with MMM-AssistantMk2 whereby when I launch MagicMirror, the module appears to be working. It makes the “beep” sound from speakers, it initiates the default call (“brief today”) but just towards the conclusion it terminates. From here I am unable to activate any command via voice. I have to activate it via mound (via VNC Viewer). If I activate by mouse it ‘hears’ my command and interprets what I am saying onto the screen, however it fails to respond.

    I ran it through npm start dev and this was the error I could see:

    MMM-Hotword.js:261 Uncaught TypeError: Cannot set property 'className' of null
        at Class.status (MMM-Hotword.js:261)
        at Class.socketNotificationReceived (MMM-Hotword.js:170)
        at module.js:246
        at r. (socketclient.js:25)
        at r.emit (index.js:83)
        at r.onevent (index.js:83)
        at r.MMSocket.self.socket.onevent (socketclient.js:19)
        at r.onpacket (index.js:83)
        at r. (index.js:83)
        at r.emit (index.js:83)

    Any assistance in this matter would be greatly appreciated.
    BJ Duncan

  • @Sean said in MMM-AssistantMk2 terminating and not activating by voice after that.:


    Woo-Hoo! - Thank you so much @Sean - That worked for me. I just reinstalled (or maybe just installed) mpg321 and it is completing the whole sentence without any cutoff. #veryHapppy 🙂

    The code I used was:

    sudo apt-get -y install mpg321

    Thanks to all that contributed to this post and I hope it helps others out just as it helped me.

    BJ Duncan

  • Would this error only occur when saying the Activation word or would it time out after 10-15 seconds and show you the error. I also encountered a similar error message but not sure on what is happening either.

  • Module Developer

    you might have not assigned the position of hotword module.

  • @blee1997 - It would not acknowledge or activate when I say “smart mirror”, “hey google” or anything. I am not even sure how to set that actual activating word/s. I assumed the default was “smart mirror”. But if I click the icon with the mouse it will listen to anything and interpret anything I say including the above mentioned words.

    @Sean - Looking through the config.js it doesn’t appear to have position, so I will give that a go also.

    Thanks for replying and I will keep at it and will reply once I have a solution.

    BJ Duncan

  • So I’m almost there now. I realised that I had the incorrect data within my config.js file as I used the configuration for v1 rather than v2. I also added the same position as the MMM-AssistantMk2 with the config.js (thanks to @Sean for that 😉 )

    My only issue now is that it still seems to terminate before completing the return request.
    Me: “Smart Mirror, what is the time?”
    (OSD: “what is the time?”)
    AssistantMk2: “The time is 8” - terminates
    (OSD: returns back to original icon immediately after termination.)
    – no ererors appear when I run this in dev mode –

    This occurs after each attempt regardless of the actual question. Could there possibly be a conflict with another module? Has anyone else come across this issue?

    BJ Duncan

  • @BJ-Duncan thats funny… it used to chop off the beginning of the reply… !

  • @sdetweil Is there some setting I need to adjust to allow it to complete the request? Have I inadvertently changed a default setting somewhere?

  • So I have been testing random things and I have noticed that if I ask it to tell me a joke, it actually completes that request. If I ask it for any type of information (eg. weather, time, who invented the telephone etc) that’s when it cuts off.

    Could it be something to do with sending a request online?

  • @BJ-Duncan no… he reworked the audio in V2 to behave better… but apparently hasn’t got it all working perfect yet…

    I noticed before similar for you… long answers worked, short were clipped

  • This is a known issue and it is tracked in

    You can try the various solutions proposed by the developer of the module. I have the same issue and I am waiting for a fix as well.

Log in to reply