MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

MagicMirror not compatible with 3.5 in screen?



  • I have tried over a dozen times to get mm to work on a 3.5 screen with a raspberry pi zero W and once I install the LCD-show it does show up on the screen but the mm won’t boot states can’t find the ecosystem config.js file I have tried 3 different LCD screens so I uninstalled pm2 and try to start it with the old standby npm start then I get a error permission denied so use sudo and the errors flow like water I have to be doing something wrong very very wrong can someone help me see the light ? Thanks
    https://solitaire.onl/ https://9apps.ooo/



  • @mishkalidas ok, l;ooks like you used sudo to install mm… so

    from the MM directory do

    chown -R pi .
    

    this will change the ownership of all the files in the mm folder and down to pi from root

    do the same for the ~/.npm folder

    cd ~
    chown -R pi .npm
    

    then npm start from the MM folder should work. without sudo
    don’t continue unless ti runs correctly

    now… on to the pm2 an’t find the ecosystem config.js file problem
    do this

    pm2 delete all
    pm2 start installers/mm.sh
       #  if mm starts correctly
    pm2 save
    

    then boot and it should work ok

    please let us know


  • Module Developer

    @mishkalidas You are also using a Raspberry Pi Zero W, last time I checked it wasn’t compatible with MagicMirror out of the box.

    Here is a quote from the MagicMirror Readme.md

    Electron, the app wrapper around MagicMirror², only supports the Raspberry Pi 2/3. The Raspberry Pi 0/1 is currently not supported. If you want to run this on a Raspberry Pi 1, use the server only feature and setup a fullscreen browser yourself. (Yes, people have managed to run MM² also on a Pi0, so if you insist, search in the forums.)

    The sudo thing is also a good idea, but I just want to raise this issue to prevent you from getting frustrated by it not working:)