Blank mm after update



  • @sdetweil said in Blank mm after update:

    how can u tell which module ‘disabled’ applies to?

    I am assuming it is sequential and that disabled: comes after module:, when present. Don’t think a ‘runaway’ disabled could exist.
    And for the purpose it serves, it does its job, IMHO.

    Perhaps it is better to first remove the leading blank space and then do the grep (and to ignore the comment parts):

    $ cat ~/MagicMirror/config/config.js | sed -e 's/^[ \t]*//' | egrep -w '^module:|^disabled:'
    

    Your piece of node.js looks nice, but how to run it standalone ?
    If used as part of a script, it makes more sense to do it this way (more control, more flexible).



  • @sdetweil said in Blank mm after update:

    module: “newsfeed”,
    disabled: false,
    disabled: false,

    I see now, that this is rather odd, not correct, without thinking too much about it.
    Does my modified command give the same result ?
    It sort of contradicts my statement on being sequential, etc.
    Or do you really have ?

    module: "newsfeed",
    disabled: false,
    disabled: false,
    
    module: "MMM-Hotword",
    disabled: false,
    disabled: true,
    


  • @evroom

    easy to run

    node scriptname.js
    


  • @evroom i have disabled, before and after module all thruout the config.js

    it is not positional

    modules: [
    	    {
          diabled: true,
          module: "alert",
        },
        {
          disabled: false,
          module: "updatenotification",
          position: "top_bar",
          config: {
            updateInterval: 3 * 60 * 1000,
            refreshInterval: 10 * 60 * 1000
          }
        }, 
        {
          module: "clock",
          position: "top_right",
          config: {
    				showWeek: false,
    				sendNotitifications: false
          }
        },
        {
          disabled: false,
          module: "calendar",
          position: "top_left",
          config: {
            showEnd: false,
            timeFormat: 'relative',
            //fetchInterval: 10000,
            calendars: [
              {
                symbol: "family ",
                //url: "https://www.ojrsd.com//site/handlers/icalfeed.ashx?MIID=11",
    
              //url: "http://localhost:8086/modules/cals/basic.ics"
              },
            ]
          }
        },
        
        {
            disabled: false,
            module: "MMM-SleepWake",
            config: {			
                delay: 5, // minutes , default = 15 minutes
                "source": 
                    "External",
                    // choices are PIR       -- uses the Raspberry pi hardware dection pins and PIR sensor
                    //      	or 
                    //             External  -- uses some external source for motion detection, like a video camera
                    //                       -- see the github motion project 
                    // mode
                    // HOW to go to sleep
                    //    use hardware(hdmi), software (dpms), or simulate (hide content leaving black screen)
                "mode":"hide",
                    // mode choices are 
                    //  'pi': 
                    //        executes the tvservice command 
                    //
                    //  'dpms'
                    //        executes the 'xset dpms force' command 
                    //
                    //  'hide'
                    //        hides all modules. modules hidden when the sleep is issued will be hidden on wakeup
                    //        for energyStar monitors and TVs, this allows the screen to remain powered on so it will come alive on movement
                    //
                //detectionDir: '/home/odroid/MagicMirror/modules/MMM-SleepWake/motion'
                    // detectionDir: folder containing externally generated file when motion starts
                    //               will be created if needed
                    // detectionFile:  filename generated for motion start. default = 'detected'
            }
        },
    {
          module: "newsfeed",
          disabled: false,
          position: "bottom_bar",
          config: {
    				ignoreOldItems:false,
            feeds: [
              {
                title: "New York Times",
                url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
              },
          /*    {
                title: "BBC",
                url: "http://feeds.bbci.co.uk/news/world/rss.xml",
    
              },    
              {
                title: "SRS",
                url: "http://feeds.news24.com/articles/news24/SouthAfrica/rss",
    
              },  */        
            ],
            showSourceTitle: true,
            showPublishDate: true
          }
        },
    		{
    				disabled: false,
    				module: 'WaterLevels',
    				position: 'top_right',
    				config : { 
    							width: 400,
    							height: 400,
    							Pins: [ 'v14','v3' ],
    								labels:['Water Usage','Water level'],
    								yaxis_legend: ['gallons used','gallons'],
    								ranges: [{"min":0,"max":200,"stepSize":100}, {"min":0,"max":2029,"stepSize":500}],
    								pinLimits: [20,1700],
    							dayrange: 3,
    							updateInterval: 5,
    							stacked: true,
    				}
    		}, 
    		{
    				disabled: false,
    				module: "MMM-ImagesPhotos",
    				position: "fullscreen",
    				config: {
    					opacity: 0.9,
    					animationSpeed: 0,
    					updateInterval: 15000,
    					backgroundColor: "#808080",
    					path: "/selectedpics",
    					debug:true
    				}
    		},	
    		{
    				disabled: true,
    				module: 'MMM-MQTTfloorplan',
    				position: 'center', // this can be any of the regions
    				config: {
    					mqttServer: {
    						url: "192.168.0.110",
    						user: "",
    						password: ""
    						},
    						
    					floorplan: {
    						image: "floorplan.png", // image in subfolder 'images'; change to floorplan.png to avoid git repository changes
    						width: 634, // this must be the width of the image above
    						height: 392, // this must be the height of the image above
    					},
    					subscriptions: [
    					/*{
    						topic: '', // MQTT Topic name
    						label: 'Living Light',	// Not displayed anywhere! 
    						type: 'door',			// Using 'door' instead 'light' to get 2-state icon
    						display: { left: 50, top: 50 },
    					},
    					{
    						topic: '',
    						label: 'First Floor Corr PIR',
    						type: 'motion',		
    						display: { left: 100, top: 150 },
    					}, */
    					{
    						topic: 'LivT',
    						label: 'Living Temp',
    						type: 'label',
    						display: { left: 44, top: 159, prefix: "", suffix: " °C", decimals: 1 },
    					},
    					{
    						topic: 'LivH',
    						label: 'Living Humidity',
    						type: 'label',
    						display: { left: 44, top: 179, prefix: "", suffix: " %RH", decimals: 0 },
    					},
    					{
    						topic: 'GuestT',
    						label: 'Guest Room Temp',
    						type: 'label',
    						display: { left: 255, top: 193, prefix: "", suffix: " °C", decimals: 1 },
    					},
    					{
    						topic: 'GuestH',
    						label: 'Guest Room Humidity',
    						type: 'label',
    						display: { left: 255, top: 213, prefix: "", suffix: " %RH", decimals: 0 },
    					},
    					{
    						topic: 'eStatus',
    						label: 'Weather',
    						type: 'label',
    						  fields: ['OAT','OAH'],
    						//key: 'OAT', //I would like to have configurable keyword for each name of object that I want display.
    						//jsonpointer: '/OAT',
    						display: { left: 55, top: 337, prefix: "", suffix: " °C", decimals: 1 },
    					},
    					]
    				}
    			},
    {
        disabled: false,
        module: "MMM-AssistantMk2",
        position: "top_right",
        config: {
          record: {
            recordProgram : "arecord",  
            device        : "default",
          },
    
          notifications: {
            ASSISTANT_ACTIVATED: "HOTWORD_PAUSE",
            ASSISTANT_DEACTIVATED: "HOTWORD_RESUME",
          },
        }
      },
      {
        module: "MMM-Hotword",
        disabled: false,
        config: {
          record: {
            recordProgram : "arecord",  
            device        : "default",
          },
          snowboy: [
          {
            hotwords: "smart mirror", //this will be sent to other module for distinguishing which hotword is detected.
            file: "resources/models/smart_mirror.umdl",
            sensitivity: '0.5',
          },
          ],
          autostart:true,
          autorestart: false,
          onDetected: {
            notification: function (payload) {
              return "ASSISTANT_ACTIVATE"
            },
            payload: function (payload){
              return {
                profile: payload.hotword
              }
            }
          },
        },
      },
    	{
    		disabled: true,
    		module: "default/SampleModule",
    		position:'middle'
    	},
    	{
    					disabled: true,
    					module: "MMM-GoogleMapsTraffic",
    		      position: "bottom_right",
    			    config: {
    			                        lat: 41.8816281,
    															lng: -87.6608605,					 
    			                height: "300px",
    			                width: "300px",
    					mapTypeId: "roadmap",
    			                styledMapType: "transparent",
    			                disableDefaultUI: "true",
    					updateInterval: "60000",
    			                backgroundColor: "hsla(0, 0%, 0%, 0)",
    			                markers: [
    			                    {
    			                        lat: 41.8816281,
    															lng: -87.6608605,
    			                        fillColor: "#9966ff"
    		                    	},
    		                	 ]
    					}
    		},	
    		{
    			  disabled: true,
    				module: "MMM-PC-Stats",
    				position: "middle",
    				config: {
    					
    				}
    		},
    	{
    		disabled: true,
    		module: 'mmm-weatherchart',
    		position: 'bottom_left', // this can be any of the regions
    		config: {
    			country: 'Germany', // as determined above
    			area: 'North_Rhine-Westphalia', // as determined above
    			city: 'Duisburg', // as determined above
    			updateInterval: 60 * 60 * 1000, // update every hour
    			hideBorder: true, // whether or not a border with city name should be shown
    			negativeImage: true, // whether or not the default white image should be inverted
    			mmDirectory: "/home/odroid/MagicMirror/" // required for caching; adjust if it differs
    		}
    	},		
    	]
    


  • @evroom modified results at least lose the comments

    module: "alert",
    disabled: false,
    module: "updatenotification",
    module: "clock",
    disabled: false,
    module: "calendar",
    disabled: false,
    module: "MMM-SleepWake",
    module: "newsfeed",
    disabled: false,
    disabled: false,
    module: 'WaterLevels',
    disabled: false,
    module: "MMM-ImagesPhotos",
    disabled: true,
    module: 'MMM-MQTTfloorplan',
    disabled: false,
    module: "MMM-AssistantMk2",
    module: "MMM-Hotword",
    disabled: false,
    disabled: true,
    module: "default/SampleModule",
    disabled: true,
    module: "MMM-GoogleMapsTraffic",
    disabled: true,
    module: "MMM-PC-Stats",
    disabled: true,
    module: 'mmm-weatherchart',
    


  • @kvicksson

    If these are the only ‘errors’ you see in the pm2 log, then it looks you are quite okay.

    As said, I personally would like to ged rid of npm audit errors, but if other board-members think it imposes a hazard to a good running system, then I would leave it. I remember that sometimes some dependencies just did not want to go away and I left it that way.

    The only thing to consider, is that you are still running on Debian jessie, where the majority probably runs using stretch and fast adopters on buster.
    I would leave this until you setup a new system.

    So, when it runs as you expect it to run, then you can close this topic and enjoy your mirror. Otherwise we will hear from you.



  • @sdetweil said in Blank mm after update:

    it is not positional

    Okay, then it makes sense.
    I have module: always first and then disabled:.
    So you see that you never can assume something 🙂

    Using your script now 👍



  • @kvicksson can u mark your issue resolved?