MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM-Ring: Displays a video stream of your Ring doorbell when someone rings your doorbell.



  • Ok, run in dev mode again but switch over to the Network tab (instead of console) and see if any of the lines have red text prior or after hitting your doorbell again.



  • i dont see any entries in the network tab at all, i have stopped and restarted the record and hit the button on the doorbell but nothing apears in the log.



  • I’ve exhausted everything I can think of. Your working with an ideal situation where everything is updated and fresh and still not able to get the stream. For some reason the videos aren’t getting dropped in that public folder for you when the event gets activated. Based on what you’ve provided it should be working.

    Since I can’t recreate the condition on my end there’s not much I can do here. Your specific issue is the first I’ve seen or heard of. That layer of the module is utilizing the ring-api from dgreif which I have no contributions to.

    If you’re adventurous enough and have a little bit of coding background you may try downloading his api and play with the browser example he has to see if you can get that working.

    Sorry @sithlordhood !



  • Ok, thanks very much for helping out.

    One final thing that i thought of was that i’m using the wired ethernet interface on the Pi, not the WiFi. Not sure if this matters, just thought it a bit odd that i did not get any data displayed in the Network tab?



  • Just to update - dont know whats changed but the module is working ok now! Thanks!



  • Hi all only a noob here would love to get my MM to show the RING video feed when someone rings the doorbell, but no idea how can anyone assist me in doing this please very much appreciated.

    Cheers

    Pete.



  • @Peter
    It’s the same for me
    I have nothing in “Network”
    I have no “Public” directory !

    Help…

    When i do /MagicMirror $ npm start dev
    I have following :

    Whoops! There was an uncaught exception...
    { Error: listen EADDRINUSE 127.0.0.1:8585
        at Object._errnoException (util.js:1024:11)
        at _exceptionWithHostPort (util.js:1046:20)
        at Server.setupListenHandle [as _listen2] (net.js:1351:14)
        at listenInCluster (net.js:1392:12)
        at GetAddrInfoReqWrap.doListen [as callback] (net.js:1501:7)
        at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:97:10)
      code: 'EADDRINUSE',
      errno: 'EADDRINUSE',
      syscall: 'listen',
      address: '127.0.0.1',
      port: 8585 }
    
    


  • did you get yours to work?, I gave up at this stage



  • @Peter-Leemon
    Still no video
    I don’t know if mmm-Ring works



  • Unfortunately, I’ve since replaced my ring devices for something more localized. I do know recently Ring had an update that requires 2-factor authentication. You may want to try setting that up and following the directions on how to use it with mmm-ring.


Log in to reply