MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

How I got my Magic Mirror working on a Raspberry Pi 0 (zero)

  • @12wsx Change the Port from 8080 to 8099 and then try again…solved a lot of problems for me…

  • After some weeks with the MagicMirror running, my SD card got corrupted and I decided to reinstall the system from scratch. I switched from “Jessie Light” to “Stretch light”, used node 6.11.4 and of course the latest MagicMirror 2.1.3.

    I can access the MM from the browser of my laptop, but Midori only shows a white page. Even for a very simple config file:

    var config = {
            address: "",
            port: 8080,
            ipWhitelist: ["", "", "::ffff:", "::1"],
            language: "en",
            units: "metric",
            modules: [
                    module: "helloworld",
                    position: "bottom_bar",
                    config: {
                            text: "Hello world!"
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}

    The start of MM gives no error

    Starting MagicMirror: v2.1.3
    Loading config ...
    Loading module helpers ...
    No helper found for module: helloworld.
    All module helpers loaded.
    Starting server on port 8080 ...
    Server started ...
    Sockets connected & modules started ...
    Ready to go! Please point your browser to: http://localhost:8080

    and if I change from

    midori -e Fullscreen -a http://localhost:8080


    midori -e Fullscreen -a

    I see the google page. So Midori itself and the output on screen seems working as well.

    Is anybody having an idea where to search for the error?
    Is anybody using MagicMirror 2.1.3 on its Pi Zero?

  • @Hawking same problem rpi 1

  • This post is deleted!

  • first set:
    set ipWhitelist: [] to allow all IP addresses.

    Warning, this enables from everywhere (on your net) have access.
    then in webbrowser go to pizero ip with port set in config ex. and check if its working

  • don’t work for me, cannot connect to destination 😞

    when i do

    DISPLAY=:0 npm start

    npm ERR! path /home/pi/package.json
    npm ERR! code ENOENT
    npm ERR! errno -2
    npm ERR! syscall open
    npm ERR! enoent ENOENT: no such file or directory, open ‘/home/pi/package.json’
    npm ERR! enoent This is related to npm not being able to find a file.
    npm ERR! enoent

    npm ERR! A complete log of this run can be found in:
    npm ERR! /home/pi/.npm/_logs/2017-10-19T18_58_10_170Z-debug.log

  • why he’s looking for /home/pi/package.json then it is /home/pi/MagicMirror/package.json ?

    This is my log


    0 info it worked if it ends with ok
    1 verbose cli [ ‘/usr/local/bin/node’, ‘/usr/local/bin/npm’, ‘start’ ]
    2 info using npm@5.3.0
    3 info using node@v8.3.0
    4 verbose config Skipping project config: /home/pi/.npmrc. (matches userconfig)
    5 verbose stack Error: ENOENT: no such file or directory, open ‘/home/pi/package.json’
    6 verbose cwd /home/pi
    7 verbose Linux 4.1.19+
    8 verbose argv “/usr/local/bin/node” “/usr/local/bin/npm” “start”
    9 verbose node v8.3.0
    10 verbose npm v5.3.0
    11 error path /home/pi/package.json
    12 error code ENOENT
    13 error errno -2
    14 error syscall open
    15 error enoent ENOENT: no such file or directory, open ‘/home/pi/package.json’
    16 error enoent This is related to npm not being able to find a file.
    17 verbose exit [ -2, true ]

  • @Doubleve
    In which directory did you execute npm start
    ? I would assume you would first go to your MagicMirror directory (cd /home/pi/MagicMirror ). This would also explain the problem with the missing package.json file.

    However, I’m not sure if npm start works at all in combination with the serveronly mode (needed for the Pi Zero). For starting, I use the method described in the first post of this thread in the section “Setting up boot scripts”.

    I can acccess my MM from remote, however still didn’t get it to show in the Midori browser 😕

  • as you said I was not in the right record.
    I had an error with the libnss3 library. Now more error

    DISPLAY =: 0 npm start

    magicmirror@2.1.3 start / home / pi / MagicMirror

    pi @ raspberrypi ~ / MagicMirror $ npm run config: check

    magicmirror@2.1.3 config: check / home / pi / MagicMirror
    node tests / configs / check_config.js

    Checking file … /home/pi/MagicMirror/config/config.js
    Your configuration file not containt syntax error 🙂

    but it still does not work with midori

  • What does npm start do in /MagicMirror