MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Rpi 4 and two monitors



  • @NathTheDude If you start a terminal on one desktop and run:

    echo $DISPLAY
    

    Then start a terminal on the other desktop and run:

    echo $DISPLAY
    

    do you get the same results?



  • @OldSunGuy - I get :0.0

    I wonder if both screens are being seen as 0.0, if that is the case I guess I would expect the MM screen to cover both screens and not just the first 😕



  • @OldSunGuy , sorry mis read your comment. Not sure how I would start a terminal on one screen and a different terminal on another.



  • @NathTheDude if they are two independent desktops, then you should have a menu on the second desktop, just like the first…

    also, you can move the mouse to the second desktop and do ctrl-alt-t to open a terminal there

    I have an micro hdmi adapter coming later today so I can put up a second physical display on my pi4…



  • @sdetweil , I opened up a terminal session on each screen and both indicated the same display was being used (:0).

    From the ‘Appearance Settings’ window (‘Prefences’ > ‘Apprearance Settings’, there is a ‘Taskbar’ tab and in this tab you select which hdmi output you want the taskbar to be on. You can choose both.



  • @NathTheDude so, it looks like one big desktop…

    u should be using Buster OS, right? so you can see the temples across the big image, some on the right display, some on the left…

    NOT the same on both?



  • @sdetweil , yeah buster.

    I can see temples on both screens, the image does not flow between screens. When looking at the 'Appearance Settings’, the is a tab for each HMDI with different settings but these are purely for what image is seen on the desktop. You can use the same image on both desktops however this is purely related to the desktop image or so is what I understand of it.



  • @NathTheDude said in Rpi 4 and two monitors:

    @sdetweil , I opened up a terminal session on each screen and both indicated the same display was being used (:0).

    From the ‘Appearance Settings’ window (‘Prefences’ > ‘Apprearance Settings’, there is a ‘Taskbar’ tab and in this tab you select which hdmi output you want the taskbar to be on. You can choose both.

    Sorry, with my previous comment - I meant to say you ‘CANT’ choose both (taskbar can only be on one screen/output).



  • @NathTheDude there is a firmware update on the pi4… execute

    sudo rpi-update
    


  • @sdetweil , so I did the firmware update and rebooted.

    Slightly different now but still can not quite get this to work. When I now run a terminal on screen 1 the output of ‘echo $DISPLAY’ is ‘:0.0’ and when I run the terminal on the 2nd window the output is ‘:0’. However the same is seen when I try to either user ‘0’ or ‘0.0’ in run.sh (mm gets display on the 1st monitor.

    I have again tried to use different numbers (1,2,3 and 0.1, 0.2, 0.3) but again, these are not valid entries.


Log in to reply