MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

~Official Topic~ MMM-GoogleAssistant - MMM-Assistant2Display



  • For my part, I have a little recurring inconvenience when I ask something to “Jarvis” this screen is often displayed

    2020-10-28-120027_1080x1920_scrot.png

    and I have to reconnect my keyboard and mouse to validate my account (I didn’t verify if the credential is the same…)
    do you know where the problem may come from?

    Sometimes also, “Javis” answers me with an echo with another voice slightly shifting, very strange…


  • Module Developer

    @RIKKO14 it’s generally happen when you use GA 2 times… Yes it’s possible!

    If you use remote-control module.it open another MM session
    So it’s not an GA bug but an remote control bug (big bug in main core)


  • Module Developer

    @pakal41 use A2D spotify recipe see wiki for helping



  • sorry @Bugsounet , I did not quite understand your answer.

    How can I use GA 2 times if I only say “Jarvis” once?
    I don’t know module.it so I didn’t not installed it so don’t think i use it, otherwise, it would have installed itself when I installed MM or its update or another module …
    should I uninstall module.it and how ?



  • @raf said in MMM-GoogleAssistant - MMM-Assistant2Display:

    @banbutcher
    you have to put MMM-Spotify on every page of the carousel

    I want the A2D Spotify info, not the mmm-Spotify info. Also I’m pretty sure I read in the wiki somewhere not to have the A2D Spotify and mmm-Spotify running at the same time!?



  • I have an issue where during electron rebuild, the js files get corrupted:

    [@bugsounet/snowboy] Do you want to execute electron rebuild ? [Y/n]
    Your choice: Y
    /home/pi/MagicMirror/modules/MMM-GoogleAssistant/node_modules/rxjs/internal/observable/bindCallback.js:1
    ������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������
    
    SyntaxError: Invalid or unexpected token
        at Module._compile (internal/modules/cjs/loader.js:723:23)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
        at Module.load (internal/modules/cjs/loader.js:653:32)
        at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
        at Function.Module._load (internal/modules/cjs/loader.js:585:3)
        at Module.require (internal/modules/cjs/loader.js:692:17)
        at require (internal/modules/cjs/helpers.js:25:18)
        at Object. (/home/pi/MagicMirror/modules/MMM-GoogleAssistant/node_modules/rxjs/index.js:61:22)
        at Module._compile (internal/modules/cjs/loader.js:778:30)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
    
    > @bugsounet/snowboy@1.6.3 postinstall /home/pi/MagicMirror/modules/MMM-GoogleAssistant/node_modules/@bugsounet/snowboy
    > tsc -p tsconfig.json
    
    
    > MMM-GoogleAssistant@2.4.13 postinstall /home/pi/MagicMirror/modules/MMM-GoogleAssistant
    > installer/postinstall.sh
    

    Any idea how I can fix that?



  • What does the “ping” written at the top of the screen mean? I don’t remember what I have to change to “false” in the config.js to remove it
    thanks !
    2020-11-04-175142_1080x1920_scrot.png



  • @RIKKO14 please don’t double post. please remove one of them

    edit: I deleted the duplicate



  • sorry & thanks sam



  • @RIKKO14 said in MMM-GoogleAssistant - MMM-Assistant2Display:

    sorry @Bugsounet , I did not quite understand your answer.
    How can I use GA 2 times if I only say “Jarvis” once?
    I don’t know module.it so I didn’t not installed it so don’t think i use it, otherwise, it would have installed itself when I installed MM or its update or another module …
    should I uninstall module.it and how ?

    @busounet,
    in addition to my last question i did not get your feedback concerning the above question and the problem that arises by very often posting the web page that asks to select an account and i don’t use remote-control module.it, and when I open the link it just wite : “We are currently working on something awesome. Stay tuned!”
    Do you have any idea what to do ?


Log in to reply