MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.
READ THE CHANGELOG BEFORE UPDATING!

MM on Pi Zero fails after being off for a few days



  • @kellogg76 i have a system that is like that… power messes up everything…

    I have moved to boot from sd card, RUN from ssd…

    https://jamesachambers.com/raspberry-pi-4-usb-boot-config-guide-for-ssd-flash-drives/
    see starting here
    USB Boot Instructions



  • @sdetweil I renamed the old MM directory and ran your script

    bash -c "$(curl -sL https://raw.githubusercontent.com/sdetweil/MagicMirror_scripts/master/raspberry.sh)"
    

    Everything went successfully, I can see the display from other computers but the pi just sits at a terminal prompt, is there something I need to do to start things off?

    $ pm2 list
    ┌────┬─────────────────────────┬─────────┬─────────┬──────────┬────────┬──────┬──────────┬──────────┬──────────┬──────────┬──────────┐
    │ id │ name                    │ version │ mode    │ pid      │ uptime │ ↺    │ status   │ cpu      │ mem      │ user     │ watching │
    ├────┼─────────────────────────┼─────────┼─────────┼──────────┼────────┼──────┼──────────┼──────────┼──────────┼──────────┼──────────┤
    │ 1  │ MagicMirror             │ 2.10.1  │ fork    │ 568      │ 2m     │ 1    │ online   │ 0%       │ 2.5mb    │ pi       │ enabled  │
    └────┴─────────────────────────┴─────────┴─────────┴──────────┴────────┴──────┴──────────┴──────────┴──────────┴──────────┴──────────┘
    


  • @kellogg76 did u install chromium-browser
    the run-start.sh script depends on it



  • @sdetweil Yes, and then rebooted for good measure. Could it be anything to do with me running Raspbian Lite and not Desktop?



  • @kellogg76 you MUST run desktop for chromium to work…

    from the shell, do

    pgrep Xorg

    it should return a number



  • @sdetweil It seemed to work well without it in the past, has something changed?
    I always found the Desktop version really laggy on the Zero so try to avoid it when not necessary.



  • @kellogg76 no idea… never tried lite
    you can certainly run serveronly… as u did and the run-start.sh executes…

    if you try to run chromium-browser
    what happens? on my pi0w desktop it comes up as expected


Log in to reply