MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

I can not change module name for MMM-JsonTable

  • Hi everyone, I insttaled that module , it works fine thanks for author.

    But I need to change module name from “MMM-JsonTable” to “MMMJsonTestKits”

    I foloowed that steps but couldnt get it, after changes module says “awaiting data” but when i revert changes , that works fine,

    Changed config array module
    module: ‘MMMJsonTestKits’,
    position: ‘bottom_left’,
    header: ‘Test Result’,
    config: {
    url: ‘’,
    arrayName: ‘entry’

    2- changed /module directory name to `MMMJsonTestKits
    3- Change Js name to “MMMJsonTestKits.js”
    4- Inside the Js, changed register module name to “MMMJsonTestKits”

    Module.register(“MMMJsonTestKits”, {

    I 'didn’t touch node_helper.js send and get socket labels.

    when I run the code , it didn’t work. (show loading)

    What is wrong with me guys?

  • @emrah_asl all good steps, do please recheck, Linux is case sensitive. so recheck each place to make sure they are all the same…

    open the developers console, using ctrl-shift-i on the MM keyboard, select the console tab, and scroll up to see any errors, (usually red text)… you should see a 401 error if the folder/filename is wrong…

  • @sdetweil

    You absolutely right , there is no error it takes time, when I wait 5 minutes it worked properly.

    Now I have go back my other problem (remotefile.json) thanks @sdetweil ! I will create another post

Log in to reply