MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-Videoplayer - Play video files on your mirror

  • Module Developer


    This Module adds a video player in any of the regions, you define what files to play.


    Simple video showing the module when playing a video and whats happen when hiding / showing it.



    If you want to change the size of the player.

    .MMM-Videoplayer video {
        width: 1080px;
        height: 1920px;

    Let’s say run the module in “fullscreen_below” and have a mirror in portrate mode (as in the CSS example above). You many want to turn the player 90 degrees…
    Then set the CSS to:

    .MMM-Videoplayer video {
        width: 1080px;
        height: 1920px;

    Normally you just need to add the line:


    But for comparability reasons, you can add all of them. 🙂

    And, as you will probably notice with the above CSS code. The video player will not really “fill” the whole background when you turn it 90 degrees. So, then you need to to this:

    .MMM-Videoplayer video {
        position: absolute;
        transform-origin: bottom left;
        width: 100vh;
        height: 100vw;
        margin-top: -100vw;
        object-fit: cover;

    Version 0.3

    • Added more “notification” commands (“REPLAY” and “NEXT”).
    • Also fixed so all videos will be played when in radom, before a video is played again (if in loop mode).

    Version 0.2

    • Added a video list option (you can define multiple video files).
    • Added a option to “randomize” the videos played from the list.

    Version 0.1

    • Initial release.

  • Hey there,

    Your module is exactly what i am looking for.

    But somehow, it does not display the movie at all.

    I tried several ways with the config file, but was not able to get it to work.

    So far i only tested with your Demo Vid, but nothing else.

    This is what i currently have in my config.js:

                        module: 'MMM-VideoPlayer',
                        position: 'bottom_left',
                        config: {

    I downloaded the Module using ‘git clone’ into the modules directory. I did not do anything else.

    I do not get a config error, so everything seems proper, but just no Video.

    Do you have any idea?

    Thank you very much!


  • Module Developer

    @feigi Hmm… I’ll have to test on my test rig tomorrow, maybe something is broken… What are you running on? I have not tried it on a RPi, so I don’t know if the Pi can handle the video-tag correctly… Is there anyone else here who can test it on a Pi? 🙂

  • Module Developer

    @feigi Hmm… I found that I had forgotten a comma in the example configs… But It looks like you have that comma in your config. I tried it on a “clean” install (on both development and master branch) and with your config and it works. What does the log say? (pm2 log).

  • Module Developer

    Added some new stuff in v0.2. See first post… 🙂

  • Module Developer

    Added some new stuff again in v0.3. See first post…

Log in to reply