MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MM fails regularly



  • So ever since updating to the latest version a few months ago, my MM seems to be failing quite often (every few days or so). Sometimes the Mirror will just freeze completely for a few hours (I know this because the clock stops) and eventually will give me a white ‘the site can’t be reached’ screen (chromium-based because I’ve got a RPi 1).
    I know it’s not disconnecting from the network because I can still ssh in and reboot the pi, which as far as I can figure is the only way to get it to work again.
    Has anyone had similar issues or knows how to find the cause (and hopefully solution) of the problem?



  • @MMRPi1 how do u start mm? pm2.

    over ssh, pm2 stop 0



  • It starts automatically when the pi boots with pm2 yes



  • @MMRPi1 can u stop rather than reboot?



  • @sdetweil I’ve tried to stop it with pm2 but it doesn’t work so I have to reboot it



  • I’ve had the same issue in the past (running on Raspberry Pi 3b). After about 1 1/2 days of continuously running it would just slow down. My solution was just to reboot it automatically (sometime during the night and then sometime before i got home from work). Works like a charm since.

    I added the below to my /etc/crontab file.
    (It also contains commands for turning on/ off my HDMI monitor for when I’m not home or am sleeping)

    FOR REBOOTING a few times every day (Raspberry Pi gets slow every other day… so reboot)

    Weekdays

    Reboot at 5:30, turn off monitor at 8:45

    Reboot at 16:00, turn off monitor at 10:00

    30 5 * * 1,2,3,4,5 root /sbin/shutdown -r now
    45 8 * * 1,2,3,4,5 root /usr/bin/vcgencmd display_power 0
    00 16 * * 1,2,3,4,5 root /sbin/shutdown -r now
    00 22 * * 1,2,3,4,5 root /usr/bin/vcgencmd display_power 0

    Weekends

    Reboot at 5:30

    Reboot at 16:00, turn off monitor at 10:00

    30 5 * * 6,7 root /sbin/shutdown -r now
    00 16 * * 6,7 root /sbin/shutdown -r now
    00 22 * * 6,7 root /usr/bin/vcgencmd display_power 0



  • @GuyWithAQuestion That actually sounds like a good solution, thanks! I’ve already got a cronjob that turns the screen off at night so I’ll try to add one to reboot every so often