MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

[MMM-TweetsByTimelineOrList] Awaiting Update... then black screen

  • I just installed the module, and using with config below.
    It shows “Awaiting Update…” when I raunch MagicMirror, then fede out in 5-10 sec.
    I see only black screen after that. Does someone help me?

    I tried regenerate API keys, add or remove some options, try with other screenName I saw on other topics.
    No error logs on console. Still no luck.


  • Project Sponsor

    @ike-9 - Have you checked the logs?

    From an SSH terminal connected to your mirror, enter pm2 log 0 and it should list the latest log entries for you. Look for any line that reads ERROR.

    Presumably, the module will tell you when something goes wrong.

  • I tried check logs but as far as I see there’s nothing indicate what I missed.
    Also, pm2 commands somehow didn’t work on my environment. Do I need to do something before execute?

  • Project Sponsor

    @ike-9 - I had assumed that you used pm2 to start the Magic Mirror process. My bad. That’s an installation thing, so no need to introduce something new.

    Hmm. Nothing in the logs, nothing in the console? That is bizarre. Let me fire this up and see if I can’t get it to work.