MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

[MMM-Remote-Control] Can not access remote control module


  • Project Sponsor Module Developer

    @motdog

    Your config entry for MMM-Remote-Control is missing a comma after position: 'bottom_left'. It’s not your fault as I see you copied it directly from the readme. I removed the comments. Try this entry below;

    {
        module: 'MMM-Remote-Control',
        position: 'bottom_left',
        config: {
            customCommand: {},
            customMenu: "custom_menu.json", 
            showModuleApiMenu: true,
            apiKey: "", 
        }
    }, 
    

    I have not tested this as I do not use this module. However, it should work for you unless something else is amiss in your config



  • @Mykle1 its weird. I have a working config. I add the module exactly as you have it, I follow the directions and it doesn’t work. I have tried adding my phone IP into the whitelist area, doesn’t work. I followed the directions from the video which match your suggestion of

    var config = {
       address: "0.0.0.0",
       port: 8080,
       ipWhitelist: [],
       
    

    and still nothing. The crazy thing is I somehow got it working once before. then i had to rebuild my config and here I am.


  • Project Sponsor Module Developer

    @motdog said in [MMM-Remote-Control] Can not access remote control module:

    then i had to rebuild my config and here I am.

    Ok, just to be sure. You rebuilt your config and now MM errors at startup, telling you to create a config? Perhaps the error is generated by something else in your config. Please post your entire config.js file here, in a code block, so that all can see it. This way, any errors will be noticed more quickly.

    Or, make a copy of the config.js.sample and rename the copy to config.js. This will get you up and running again. Then you can add one module entry at a time, saving each time you are successful. When an addition fails, you know where the problem is.



  • @Mykle1 my bad. I am confusing on this. I did a fresh reboot of the whole thing using Jesse instead of Raspian stretch and don’t have the start up issues. I rebuilt the config like I wanted with all of the modules working good. I then add the remote module and change the address etc and get the please make a config file error. As soon as I remove the remote control info things work again. So I know the error comes when I add this module. The frustrating thing is at a previous point I was able to get the remote control module working. That’s why I am confused but here is my working config without remote control.

    Thanks for your patience with me on this

    
    
    var config = {
    	address: "localhost", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	language: "en",
    	timeFormat: 12,
    	units: "imperial",
    
    	modules: [
    		{
    			module: "alert",
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			module: "clock",
    			position: "top_left"
    		},
    		{
    			module: "calendar",
    			position: "top_left",
    			config: {
    				calendars: [
    					
    {
    						symbol: "calendar-check",
    						url: "http://kuathletics.com/calendar.ashx/calendar.ics?sport_id=4&schedule_id=0&_=dd9bfb6f-df5f-4a47-9975-dd3bb74bd06a"
    					},
    
    					{
    						symbol: "calendar-check",
    						url: "https://calendar.google.com/calenxxxxxxxxxxx7495e80bc22/basic.ics"
    					},
    
    					{
    						symbol: "calendar-check",
    						url: "http://ical-cdn.tex3xxxxxxxxxx4e056117.ics"
    					},
    
    					{
    						symbol: "calendar-check",
    						url: "http://ical-cdn.teamsnap.com/team_schedule/xxxxxxxxxxa68b.ics"
    					}
    				]
    			}
    		},
    
    		{
    			module: "compliments",
    			position: "lower_third"
    		},
    
    			{
    	        module: 'MMM-NOAA3',
    		position: 'bottom_left',
    	        config: {
    			    provider: "darksky", 
    			    apiKey: "6462c3f6d7c6dxxxxx311",         
    			    airKey: "WZzmCBxxxxxmBM",    
    		        css: "NOAA4",                    
    			userlat: "x8.7xx9",  
    		        userlon: "-x0.5xx" 
    	 }
             },
    
    
    
    		{
    			  module: "MMM-NowPlayingOnSpotify",
    			  position: "bottom_right",
    			
    			  config: {
    			    clientID: "85d8bxxxxxxx",
    			    clientSecret: "e6b226e4b819xxxxxx",
    			    accessToken: "Bxxxi-UItbKL3NR1dQXpC8sJ1041J5NjVeafoAb3fGVsicRUataJodmfa1urp0akDwThbo",
    			    refreshToken: "AQBP1w70KP5TqlxiFNgA4RU6mdTct0AHb58nasw2sEpl17iIz-uPDq9M0ifITQcOxxxxxx"
    			  }
    },
    
    
    
    		{
    			  module: "MMM-MyScoreboard",
    			  position: "top_right",
    			  classes: "default everyone",
    			  header: "My Scoreboard",
    			  config: {
    			    showLeagueSeparators: true,
    			    colored: true,
    			    viewStyle: "mediumLogos",
    			    sports: [
    			      {
    			        league: "NHL",
    			        teams: ["STL"]
    			      },
    			      {
    			        league: "NBA",
    			        teams: ["BOS", "GS", "HOU", "PHI"],
    			        
    			      },
    			      {
    			        league: "MLB",
    				teams: ["STL"]
    			        
    			      },
    			      {
    			        league: "NFL",
    			        
    			      },
    				
    				
    			      {
    			        league: "NCAAM",
    			        groups: ["Top 25"]
    			      }
    			   
    			    ]
    			
    			  }
    			},
    
    
    
    		{
    			module: "currentweather",
    			position: "top_right",
    			config: {
    				location: "New York",
    				locationID: "",  //ID from http://bulk.openweathermap.org/sample/; unzip the gz file and find your city
    				appid: "YOUR_OPENWEATHER_API_KEY"
    			}
    		},
    		{
    			module: "weatherforecast",
    			position: "top_right",
    			header: "Weather Forecast",
    			config: {
    				location: "New York",
    				locationID: "5128581",  //ID from https://openweathermap.org/city
    				appid: "YOUR_OPENWEATHER_API_KEY"
    			}
    		},
    		{
    			module: "newsfeed",
    			position: "bottom_bar",
    			config: {
    				feeds: [
    					{
    						title: "New York Times",
    						url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
    					}
    				],
    				showSourceTitle: true,
    				showPublishDate: true
    			}
    		},
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    
    


  • @motdog whenever you get the ‘create a config file’ error, run

    npm run check:config
    

    and work thru the errors from the top down


  • Project Sponsor Module Developer

    @motdog

    I went and installed MMM-Remote-Control on a laptop running ubuntu and MM v2.5.0. I used this config entry:

    0_1551667234525_Screenshot from 2019-03-03 21-40-00.png

    The module loads (bottom right):

    0_1551667367462_Screenshot from 2019-03-03 21-41-36.png

    I’ll send a picture from my other machine. brb


  • Project Sponsor Module Developer

    @motdog

    You can clearly see that it is working remotely.

    0_1551667630017_Screenshot from 2019-03-03 21-45-43.png

    It would not allow connection with address: "localhost",. Take your working config and carefully add my entry for Remote-Control, address and ipWhitelist It should work.



  • @Mykle1 Awesome! Thanks so much for your help.


  • Project Sponsor Module Developer

    @motdog

    So, does that mean that it’s working for you now? If so, mark the topic as solved.



  • Hi, i too have the same issue. I have changed my router IP to be something other than 192.XXX.X.XX

    Could this be the problem? I can access via browser on the Pi…?

    When i run the remote in browser on the pi, i notice in terminal this message:

    MMM-Remote-Control customMenu Requested, but file:/home/pi/MagicMirror/config/custom_menu.json was not found
    
    

    i receive an “Access Denied to IP address 10.100.10.1” in terminal and a message on m y phone saying the device is not allowed to access your mirror

    Here is config code:

    address: "0.0.0.0", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: [ "127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:10.100.10.0/24",], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	language: "en",
    	timeFormat: 24,
    	units: "metric",
    

    And here is my module code:

    {
    		module: 'MMM-Remote-Control',
    		/**position: 'bottom_left',**/
    		config: {
    			customCommand: {},  // Optional, See "Using Custom Commands" below
    			customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
    			showModuleApiMenu: true, // Optional, Enable the Module Controls menu
    			/**apiKey: "",         // Optional, See API/README.md for details**/
    		}
    	},
    

    The module code is pretty much the defaults.


Log in to reply