MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

[MMM-Remote-Control] Can not access remote control module

  • I have just commented out the custom menu for now, so ignore that terminal message about it

    		module: 'MMM-Remote-Control',
    		/**position: 'bottom_left',**/
    		config: {
    			customCommand: {},  // Optional, See "Using Custom Commands" below
    			/**customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below**/
    			showModuleApiMenu: true, // Optional, Enable the Module Controls menu
    			/**apiKey: "",         // Optional, See API/ for details**/

  • @Mykle1 my only other question is when I was at a friend’s house I tried to pull up the remote to show them the mirror & nothing happened on their wifi or cellular. I’m guessing on the white list I would have to input my phone ip address?

  • @motdog lot more than that…

    by default your home router blocks ALL incoming requests (or should anyhow) so you would have to open a port and map incoming requests on that port to your mirror machine (and port) by using the routers admin function… some providers do not allow this
    (this is called port forwarding)

    second, the IP address of the router on the internet is assigned dynamically, and might change…
    some of us use a dns mapper to define a specific NAME to our router as it appears on the internet
    ( I use to map a known name to my router ip address, today my routers internet ip address is near

    third, the ip address of your phone will be randomly assigned too… their router, maybe over phone link connection… so , here u might have to say anyone…

  • Project Sponsor Module Developer

    @motdog If you open up a port for outside access of MM you’ll have to whitelist all IP’s since your phone changes IP. You will then expose it for everyone. This includes the config.js file, which might contain passwords to calendars etc. So be careful! Best option is to connect to your network using VPN. It is possible to setup a VPN server in some routers.

  • @retroflex he will still have to whitelist everything, or use Listen:

  • Thanks for all the feedback. I get the concerns and why its set up that way. No big deal at all

  • So I still get access denied, but if i change

    ipWhitelist to [] then my phone can now access the remote page.

    Just dont understand when I have address the correct ip for my phone it says access denied to that same ip in the terminal


    ipWhitelist: [ "", "::ffff:", "::1", "::ffff:",],


    ipWhitelist: []

  • Hello,

    I know the topic is old, but may someone can help me.

    The module is shown on my screen but when I want to enter via Browser it always shows: This site cant be reached.

    alt text

    when erase the // from the config: The screen shows me an error, I should install a config data.

    Can someone help me?


  • @Mr-Gysy position: “bottom_right” needs a comma after when the next line is NOT a comment

  • @Mr-Gysy
    I see you have:

        adresss: “”,  

    It should be:

         address: “”,  

    Just a user helping another user

Log in to reply