MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Mirror mirror on the wall alexa skill



  • @KMH0 create a new folder inside the src folder, call it certs, then place the files you downloaded and the generated root-CA.crt in it. I just started to create a guide with screenshots, but it will take me some time, in the meanwhile, you can just ask me



  • @joanaz Would have been awzome! Thanks for the help 🙂



  • @KMH0 screenshots are added! let me know if the guide still doesn’t make sense



  • @joanaz I was able to config the skill and get it working. Now I’m trying to get it working with the MirrorMirrorOnTheWall module and I’m running into some issues. I’ve copied the cert folder into MagicMirror/modules/MMM-MirrorOnTheWall directory. The next step says to replace keyPath, certPath and caPath with your own credentials’ path, but inside MirrorMirror.js, it’s already defaulting to __dirname + “certs/MagicMirror.private.key”. Booting up MirrorMirror on the wall and invoking On the Wall, Alexa says “there was a problem with the requested skills response”. Now if I run tests in Service Simulator on AWS the lambda response is “The remote endpoint could not be called, or the response it returned was invalid.”

    Any ideas?



  • @ring23 said in Mirror mirror on the wall alexa skill:

    @joanaz I was able to config the skill and get it working. Now I’m trying to get it working with the MirrorMirrorOnTheWall module and I’m running into some issues. I’ve copied the cert folder into MagicMirror/modules/MMM-MirrorOnTheWall directory. The next step says to replace keyPath, certPath and caPath with your own credentials’ path, but inside MirrorMirror.js, it’s already defaulting to __dirname + “certs/MagicMirror.private.key”. Booting up MirrorMirror on the wall and invoking On the Wall, Alexa says “there was a problem with the requested skills response”. Now if I run tests in Service Simulator on AWS the lambda response is “The remote endpoint could not be called, or the response it returned was invalid.”

    Any ideas?

    Did you resolve this problem? I’m also stuck at the steps to create cert folder. Should it be created in the modules dir? The manual says ’ copy all your credential files, then go to your local copy of this repo, and paste them inside the certs folder (which is inside the src folder)" but I don’t see src folder?



  • @goprojojo

    I had the same issue adding a host value to the device constructor in mirormirror.js after line 16 did the trick for me.
    You can find it in the AWS IOT settings panel.

    app.device = awsIot.device({
        keyPath: __dirname + "/certs/MagicMirror.private.key",
        certPath: __dirname + "/certs/MagicMirror.cert.pem",
        caPath: __dirname + "/certs/root-CA.crt",
        clientId: "MirrorMirror" + (new Date().getTime()),
        region: "us-east-1",
        host: "************.iot.us-east-1.amazonaws.com",
      });
    


  • Hi all,
    Just delving into the world of SmartMirrors, if there’s anyone that can help me with this last little bit it would be amazing!
    I have followed Joanaz insanely good guide (thank you!!) and I too got stuck with the connection issue. Thanks timjong for your pointer, I think I’ve edited that file correctly and added the host in.
    Uploading, saving and testing in lambda setup then gives me this error:

    {
      "errorMessage": "2017-11-15T21:05:12.504Z a94c5f8d-ca48-11e7-8d56-b5963befba0d Task timed out after 3.00 seconds",
      "errorType": "SyntaxError"
    }
    

    This is what I have in that section of my mirror.js file, I’ve only added the host line so hope I’ve done it right.

    app.setup = function() {
      app.device = awsIot.device({
        keyPath: __dirname + "/certs/MagicMirror.private.key",
        certPath: __dirname + "/certs/MagicMirror.cert.pem",
        caPath: __dirname + "/certs/root-CA.crt",
        clientId: "MirrorMirror" + (new Date().getTime()),
        region: "us-east-1",
    host: "**********vuct.iot.us-east-1.amazonaws.com",
      });
    

    Anything obvious or any suggestions what to try next?
    Thank you
    Noel



  • @noelandrews Hey Noel, I’m getting the same error. Did you ever find a resolution to the time out error?



  • Afraid not, sorry need so,e help from people much more switched on than me!



  • @noelandrews I got mine working actually. Missed the small step of making a copy of keys_sample.json and calling it keys.json. index.js couldn’t call the proper keys then. Dumb mistake


Log in to reply