MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MagicMirror on Pi Zero W

  • @Iseknutz
    What do you mean by “after the Update to the actual OS”? I used the image linked above. I can’t do an update/upgrade as I have no internet connection. I’m using the console on the Pi and editing my conf in Mint Linux. I’m using Jessie Lite rather than the full install.

    Thanks for the rewrite on the wpa_supplicant, but it still won’t connect to any provided wifi network.

    Thanks to all.

  • @kylelmartin I have connected an USB Wlan Dongle (Edimax, working without extra software) and do the update. Im using Jessie Lite and later I installed the desktop.
    Sorry for my bad english 😉

  • @Iseknutz

    Greetings from Toulouse. To do the update and upgrade, from the terminal type:

    sudo apt-get update
    sudo apt-get upgrade

    After the installation of the new updated packages, sudo shutdown. Wait. Remove the power and your edimax adapter and connect power. Now does it work?


  • @CaptnJB @Iseknutz

    Silly me! I should have known that to get a wifi adapter to work I needed a wifi adapter!
    Fortunately I had a usb splitter with power supply and an edimax wifi lying around.

    After the update and upgrade its working well.
    Your help was greatly appreciated.
    Thanks from Texas!

  • @rootsudo Thank you!

    This along with post number 23 got my Pi Zero and Pi zero W working perfectly 🙂

  • @rootsudo said in MagicMirror on Pi Zero W:

    The Beginnings:

    1. Place wpa_supplicant.conf in Boot folder of SD card
    2. Boot SD card and login
    3. Enable SSH: sudo raspi-config -> Select Interfacing Options -> select SSH -> select Enable -> select Finish

    After step 4 i recommend creating an empty file called “ssh” and also put it in the Boot folder of the SD card.
    So you don’t have to do step 6, cause ssh is started on boot with the default credentials (user: pi, password: raspberry)

    After boot, it did not open the browser, instead it just showed the console window.
    Problem was solved by installing x-server with sudo apt-get install xserver-xorg

  • my I please someone to make an image of sd card with installed and working MM? i’m trying about week to run MM on piZero and nothing… all the time diffrent errors which i don’t understand.

  • This post is deleted!

  • tried on stretch lite and got this

    pi@raspberrypi:~/MagicMirror $ sudo npm install
    npm WARN engine http-auth@3.2.3: wanted: {"node":">=4.6.1"} (current: {"node":"4.2.1","npm":"2.14.7"})
    npm WARN deprecated coffee-script@1.10.0: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
    npm WARN engine apache-crypt@1.2.1: wanted: {"node":">=4.6.1"} (current: {"node":"4.2.1","npm":"2.14.7"})
    npm WARN engine apache-md5@1.1.2: wanted: {"node":">=4.6.1"} (current: {"node":"4.2.1","npm":"2.14.7"})
    npm WARN engine hawk@6.0.2: wanted: {"node":">=4.5.0"} (current: {"node":"4.2.1","npm":"2.14.7"})

Log in to reply