MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.
READ THE CHANGELOG BEFORE UPDATING!

[MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras



  • @Hram2008 said in [MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras:

    Has anyone been able to get this working with Axis camera products?

    Yes, I have.

    Please show your MMM-RTSPStream part from config.js.


  • Module Developer

    @Hram2008 have you tried running the URL straight with OMX to see if it works, if it does, you may have issues with the plugin itself, and as the author seems to have disappeared, you could just replace the plugin with OMX cutting the proper hole out of the window (It’ll go in front of whatever is running, so you run it independently, and it just works.

    omxplayer --no-osd --no-keys --avdict rtsp_transport:tcp --live --fps 30 --orientation 0 --win "640 0 1280 360" [URL]
    
    -or- 
    
    omxplayer --no-osd --no-keys --avdict rtsp_transport:udp --live --fps 30 --orientation 0 --win "640 0 1280 360" [URL]
    
    


  • Hello everybody!
    I’m trying to set up the module by doing some tests.

    I am using this configuration, using the test stream recommended by the developer “rtsp://184.72.239.149/vod/mp4:BigBuckBunny_115k.mov”:

    {
    		   module: "MMM-RTSPStream",
    		   //position: "middle_center",
    		   pages: {Security: "middle_center"},
    		   header: "Test",
    		   config: {
    				autoStart: true,
    				rotateStreams: false,
    				rotateStreamTimeout: 10,
    				moduleWidth: 354,
    				moduleHeight: 240,
    				localPlayer: 'omxplayer',
    				remotePlayer: 'none',
    				showSnapWhenPaused: false,
    				remoteSnaps: false,
    				stream1: {
    					name: 'BigBuckBunny',
    					url: 'rtsp://184.72.239.149/vod/mp4:BigBuckBunny_115k.mov',
    					frameRate: 'undefined',
    					width: undefined,
    					height: undefined,
    						},
    					}
    		},
    

    The module starts but I don’t see anything.
    Below is a screen shot of the MM:

    2020-04-02-144902-1920x1080-scrot

    Where am I wrong?

    Thank you all.


  • Project Sponsor

    @Egnos - Have you checked to make sure there is something at that URL? I punched it into VLC and got connection failed.



  • @bhepler thanks for the answer.
    I thought it was just my problem.
    I found the link on the gitHub page.
    The developer recommends using this link for testing and I thought it worked.

    Do you know any public links to test the module?

    Regards.



  • Try this link:

    rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov



  • Many thanks @evroom, the link works in VLC but still doesn’t work in MM.

    Below what I see on the terminal:

    [10:58:31.986] [LOG]    Starting stream stream1 using: omxplayer --avdict rtsp_transport:tcp --win 786,238,1138,480 --live --video_queue 4 --fps 30 --no-osd rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
    [10:58:32.033] [LOG]    Starting PM2 for omx_stream1
    [10:58:43.404] [LOG]    PM2 started for omx_stream1
    

    Are there any errors in config.js?

    		{
    		   module: "MMM-RTSPStream",
    		   //position: "middle_center",
    		   pages: {Security: "middle_center"},
    		   header: "Test",
    		   config: {
    				autoStart: true,
    				rotateStreams: false,
    				rotateStreamTimeout: 10,
    				moduleWidth: 354,
    				moduleHeight: 240,
    				localPlayer: 'omxplayer',
    				remotePlayer: 'none',
    				showSnapWhenPaused: false,
    				remoteSnaps: false,
    				stream1: {
    					name: 'BigBuckBunny',
    					url: 'rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov',
    					frameRate: 'undefined',
    					width: undefined,
    					height: undefined,
    						},
    					}
    		},
    

    Thanks for your patience!



  • @Egnos said in [MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras:

    the link works in VLC but still doesn’t work in MM

    Hi,

    What does this say ?

    pm2 logs --lines 100
    

    The part where you should see

    0|MagicMirror  | Starting stream stream1 with args: [
    

    And

    pm2 status
    

    should show

    omx_stream1
    

    And can you try it from the command line ?

    omxplayer --genlog --avdict rtsp_transport:tcp --live --video_queue 4 --fps 30 --win "0 0 354 240" rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
    


  • Hi @evroom ,

    @evroom said in [MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras:

    What does this say ?
    pm2 logs --lines 100

    I never posted this …!

    I launched the command on the terminal you recommended but I still don’t see anything, here is the result:

    pi@MagicMirror:~ $ omxplayer --genlog --avdict rtsp_transport:tcp --live --video_queue 4 --fps 30 --win "0 0 354 240" rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
    Video codec omx-h264 width 240 height 160 profile 578 fps 30.000000
    Audio codec aac channels 2 samplerate 12000 bitspersample 16
    Subtitle count: 0, state: off, index: 1, delay: 0
    V:PortSettingsChanged: 240x160@30.00 interlace:0 deinterlace:0 anaglyph:0 par:1.00 display:0 layer:0 alpha:255 aspectMode:0
    
    

    And this the log “omxplayer.log”:
    omxplayer.log

    I paste all the info that the MM prints on the terminal:

    > magicmirror@2.10.1 start /home/pi/MagicMirror
    > ./run-start.sh
    
    [19:45:33.744] [LOG]    Starting MagicMirror: v2.10.1
    [19:45:33.792] [LOG]    Loading config ...
    [19:45:33.805] [LOG]    Loading module helpers ...
    [19:45:37.253] [LOG]    Initializing new module helper ...
    [19:45:37.255] [LOG]    Module helper loaded: MMM-RTSPStream
    [19:45:37.256] [LOG]    All module helpers loaded.
    [19:45:37.257] [LOG]    Starting server on port 8080 ... 
    [19:45:37.346] [LOG]    Server started ...
    [19:45:37.348] [LOG]    Connecting socket for: MMM-RTSPStream
    [19:45:37.350] [LOG]    PM2: Stopping all OMXPlayer Streams...
    [19:45:37.352] [LOG]    Sockets connected & modules started ...
    [19:45:38.246] [LOG]    Launching application.
    [19:45:46.329] [LOG]    Starting stream stream1 using: omxplayer --avdict rtsp_transport:tcp --win 786,238,1138,480 --live --video_queue 4 --fps 30 --no-osd rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
    [19:45:46.426] [LOG]    Starting PM2 for omx_stream1
    [19:45:53.630] [LOG]    PM2 started for omx_stream1
    
    

    I don’t understand what’s missing…



  • @Egnos said in [MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras:

    I don’t understand what’s missing…

    It does look good.

    In principle, the line from the pm2 log

    [19:45:46.329] [LOG]    Starting stream stream1 using: omxplayer --avdict rtsp_transport:tcp --win 786,238,1138,480 --live --video_queue 4 --fps 30 --no-osd rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
    

    should work as standalone.
    If it does not play standalone, so from the command line, then it will not work in MMM-RTSPStream.

    I would disable the module and make sure nothing is running anymore (no omxplayer stuff).

    module: "MMM-RTSPStream",
    disabled: true,
    
    pm2 restart mm
    pm2 status
    

    Make sure ‘omx_stream1’ is not present.
    Stop it when necessary

    pm2 stop omx_stream1
    pm2 delete omx_stream1
    
    ps -eaf | grep -v grep | grep omxplayer
    

    Kill any omxplayer process (kill -9 ).

    Then run omxplayer from command line:

    omxplayer --avdict rtsp_transport:tcp --win 786,238,1138,480 --live --video_queue 4 --fps 30 --no-osd rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
    

Log in to reply