MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Blocking MagicMirror from the Web.

  • Good Day All

    I am trying to make a MagicMirror that can play music as well. That is the big goal here. But I’ve hit a rather silly snag.

    I am running Mopidy for the music and the MagicMirror for the Display, but the two refuse to run at the same time… Guessing it has to do with the Mopidy creating a “server” and the MagicMirror trying to then use the internet.

    A work around that I was hoping to try is get the MagicMirror to boot up get all the upcoming holidays and time then disconnect itself from the internet and let Mopidy create its server… Maybe then once a day I could let the MagicMirror update or something like that.

    So my question is: “How can I get MagicMirror to boot, update and then not use the internet?”

  • problem Solved, By changing the port of the Mopidy to 8081 and all was well.

  • @Terrence
    Hello, can you tell me where and how you managed to change the port?
    Thank you

  • Ofcourse Damian…

    In the config files for both I could just change the port settings.

    sudo nano ~/MagicMirror/config/config.js
    The port is the first Variable in the config section (default: 8080)

    sudo nano ~/.config/mopidy/mopidy.conf
    Here I uncommented the [http] section and for the hostname I used the Pi’s IP and port is 8081.

    This solved the problem and I am now able to run my MagicMirror and Mopidy at the same time…

  • sounds interesting. Do you control it with a touchscreen?
    Can you maybe upload a screenshot how it looks like?

  • No I want to be able to control it from anywhere in the house. So I am using the Mopidy web App to control the music and the display just shows the mirror as per the usual magicmirror…

    Will put up some photos when it actually takes shape.

  • @Terrence
    Thank you for that, do you import from local, or from external ? If local how did you manage to link to source?

    Thank you

  • Hey Sorry for the long wait. I’ve been having a lot of trouble with playing it locally actually…

    I put all my music on the SD card under the /home/pi/music/ file…
    So in the /etc/mopidy/mopidy.conf under the [local] function I added the /home/pi/music/ as the dir…
    Then I did a local scan and it pulled all my music in.

  • @Terrence
    No problem mate. Thanks for info as thats gives me a head start to work on as I intended pulling in from my main networked PC that has all my media on it, and far too much music for even the biggest of sd cards 🙂 so will play about with your settings and see if I can maybe link it to my PC?

    Thanks again.

Log in to reply