MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.
READ THE CHANGELOG BEFORE UPDATING!

Motion Detector



  • @chrisvanlaar said in Motion Detector:

    After reading here the motion works on my MM.
    Now ik want to go out of the sleep mode when a new mail or i get a phonecall. (it reads from my Fritzbox).
    Can i build in this option also? or is it better in the phone/mail module.

    Chris

    I mean that i have the camera module connected to my PI3. In the /boot/config.txt i had the (@reboot sudo modprobe bcm2835-v4l2 ) and it works! 🙂

    Chris



  • Hi All,

    I’ve revamped the motiondetector module to use a more optimised code to detect the motion from the web camera. The old one was performing very poorly. The new code works many times better. Just pull the latest from

    https://github.com/alexyak/motiondetector

    • Alex


  • Hi Alex,
    thank you so much for your work! Unfortunately my MM start with a black screen after the update. I tried to reboot my Raspi but it didn’t help. Should I make a npm install after the update?
    THX



  • and this is the error:
    error



  • @trividar My apologies. This should be fixed. Just pull the latest.



  • @alexyak Now my MM start. But after awhile (2 min) i got this error and my MM freeze:

    alt text

    I disabled the DHT module but than i got this error:

    alt text

    Do you have also a solution for this? THX a lot!



  • @trividar I don’t see anything related to the motiondetector in your logs. It seems the error coming from the mmm-systemperature/node_helper.js



  • I disabled mmm-systemperature and now I have no errors on my log but after first deactivation of the monitor my raspberry freeze completely. Before the pull everything works perfekt beside DHT, now nothing works ;o( strange…



  • @trividar I’m having a similar issue. My mirror will turn on and off a few times, but after a few minutes it will peg the RAM and completely lock up the pi. Not sure what to try next.



  • @jdahli1

    I have also experienced something similar, always while running under a heavy load. Are you running a lot of modules, or anything that is very intensive? Some tasks like video streaming are incredibly demanding on the CPU.

    My working solution was to modify my module selection so I’m not overworking the processor, and to increase the ‘updateInterval’ in my SystemStats section of config.js. Maybe try 15000 or 20000ms, see if it the crash occurs less often. I also run WatchDog and it would register the SystemStats failure. I don’t see WatchDog in these logs so this may not apply, but I also added increased ‘interval’ and ‘timeout’ settings to config.js. I have not seen this SystemStats crash for quite a while.

    FWIW - after this crash WatchDog/pm2 does NOT restart my mm shell. All the other failures auto-restart, but something about this one crashes to the desktop. Also - sorry for threadjacking a “Motion Detection” thread!


Log in to reply