MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-RTSPStream dosent work in my case

  • Here is my working config.

                    module: 'MMM-RTSPStream',
                    position: 'bottom_left',
                    config: {
                            autoStart: true,
                            rotateStreams: false,
                            rotateStreamTimeout: 10,
                            showSnapWhenPaused: false,
                            moduleWidth: 352,
                            moduleHeight: 240,
                            moduleOffset: -20,
                            localPlayer: 'omxplayer',  //omxplayer oder ffmpeg
                    stream1: {
                            name: 'Door',
                            url: 'rtsp://', //update with your IP
                            snapshotUrl: '',
                            snapshotRefresh: 10, // Seconds
                            frameRate: "30",
                            port: 9999,

    i would suggest, you only change the IP adress, without port or the authbasic stuff…
    I also have password set, but for some reason, i do not need to pass it to the module.
    I played around a little bit, but as soon as i change the port or something… it does not work anymore.
    Maybe worth a try.
    Otherwise, bring the developer in here… he is very helpful and has for sure another tips you can try.

  • Thanks barnosch,
    I think I’ve solved the problem: D
    I think because I’m working remotely and I can not see if the stream is shown or not but I trust.
    I practically lost a pass that eliminated the sound.
    So I think that everything is resolved.
    I see the stable connection from the remote console and then almost for sure that the module now works.
    I find it in issue.
    The command it solves is:
    git fetch - all
    git checkout nosound

    I’ll let you know as soon as I see it with my eyes

  • Solved !!

  • Module Developer

    @alverman – I’m the creator of the module and I wanted to apologize, I’ve been working on other projects and not following this forum very closely the past few months. I’m glad you got everything solved, I’m sorry I wasn’t able to assist.

    In the future, if you have any issues with one of the modules I created, please tag me (@shbatm) or open an issue on the module’s Issue page at so I get a notification and will be happy to assist.

  • Can you share your final configuration?

Log in to reply