MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Two Instances in PM2

  • I’m sure there’s a really simple fix for this, it looks like somehow I’ve managed to get 2 instances of MagicMirror to start on boot up

    │ Name        │ mode │ status │ ↺ │ cpu │ memory   │
    │ MagicMirror │ fork │ online │ 0 │ 0%  │ 2.3 MB   │
    │ mm          │ fork │ online │ 0 │ 0%  │ 2.3 MB   │

    Is there a simple way I can remove the mm process altogether? Or simply just disable it from booting up?

  • Project Sponsor Module Developer


    pm2 stop mm
    pm2 delete mm
    pm2 save
    rm ~/

    Then check your instances again. 🙂

  • @Mykle1 Worked perfectly, thanks!!

  • Project Sponsor Module Developer


    Cheers, mate! 🙂

  • Had exactly the same issue. Thought I’d resolved it and then it came back after reboot. Following these instructions worked.

  • Hello:)

    I run it on a Pi ZeroW and I know that’s not the common way. I use PM2 since I could not find any other working solution for Jessie or Stretch. Though it starts MM and chromium and everything looks well, the CPU is at 100 % all the time. When checking the active processes, the “node server only” is listed four times and chromium twice. Each node instance eats up to 20 % of CPU time.

    Any idea how to stop that?

  • @mykle1 hi again☺️. Hope u are well. I had this same problem. I ran your suggestions and now I only have MagicMirror and not mm. However. When I pm2 start MagicMirror. It shows it’s “online” yet fails to go onto mirror mode. Please help. I don’t want to start from scratch. Also how do I stop the screen going into sleep mode? Thnx @Mykle1 you have been my MM life support thus far!!!

  • Project Sponsor Module Developer


    Hey shaz. I’m well, thanks. How are things down under? 🙂

    Sounds like you might be in node server only mode, perhaps.

    What happens if you navigate to the MagicMirror folder in your terminal and type npm start? Does the mirror run as expected then?

    Worst case scenario (I think) is you would have to delete PM2 altogether and re-install using the guide from the MM repo. Unless someone has a better idea. (They usually do) 🙂

  • @mykle1 hi. So glad to hear you are doing well. Bit chilly here in SA but all good thnx.
    Ok so I went into the MagicMirror module in terminal as you suggested and ran npm start. It ran a whole bunch of lines then went into Mirror mode. Everything is there. Then to stop it I held control + q to stop. It stops it and puts me back to the terminal I started in. How for demo purposes would I go in and out of the mirror now? How do I get it back to easy access? And what did I do wrong? On install when it asked do u want to use pm2 I said Y. Then is new clean terminal I did pm2 startup. I copied and pasted the line required. I rebooted. Then typed nano and added ~/MagicMirror
    DISPLAY=:0 npm start
    Saved then typed
    Chmod +x
    Then typed pm2 save
    That’s where I get two instances one MagicMirror that won’t respond until ur way
    And the other is mm which I deleted with your thread instructions.
    So how do I get easy in and out of mirror mode? Thanx my life saver once again!

    Also. I can’t disable the screen saver with the new version. How do I stop it now?
    Thnx. Look forward to hearing from you😉

  • @mykle1 ok. Don’t worry about screen saver. Sorted that out. But not sure how I did it. LOL!

Log in to reply