MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

MMM-Remote-Control show error on start

  • Hey guys,

    i freshly installed MM manually on a RPi 3 with Raspbian Jessie.

    MM starts and i am able to use the Remote Control, but i also get this error from the Remote-Control module. The error is shown 4 times directly behind each other.

    0|mm       | Whoops! There was an uncaught exception...
    0|mm       | TypeError: Cannot read property 'replace' of undefined
    0|mm       |     at /home/pi/MagicMirror/modules/MMM-Remote-Control/node_helper.js:240:24
    0|mm       |     at /home/pi/MagicMirror/modules/MMM-Remote-Control/node_modules/simple-git/src/git.js:768:18
    0|mm       |     at Git. (/home/pi/MagicMirror/modules/MMM-Remote-Control/node_modules/simple-git/src/git.js:808:18)
    0|mm       |     at done (/home/pi/MagicMirror/modules/MMM-Remote-Control/node_modules/simple-git/src/git.js:1354:21)
    0|mm       |     at ChildProcess. (/home/pi/MagicMirror/modules/MMM-Remote-Control/node_modules/simple-git/src/git.js:1379:16)
    0|mm       |     at emitTwo (events.js:106:13)
    0|mm       |     at ChildProcess.emit (events.js:191:7)
    0|mm       |     at Process.ChildProcess._handle.onexit (internal/child_process.js:215:12)
    0|mm       | MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    0|mm       | If you think this really is an issue, please open an issue on GitHub:

    How i already said… i can access the Mirror by http://my.RPi.IP.address:8080/remote.html

    So everything is working fine, but i don’t know why this occurs

  • @cruunnerr Just from the stack trace and mention of git, I have a suspicion that this where MMM-Remote-Control polls Github for the git status of each installed module (are you running four third-party mods?). If MM is still working, it seems that it fails gracefully and is not causing problems. It appears that its node_helper.js on line 240 has a replace() call that is not receiving a proper string (or regex?).

  • Hmm,

    i am running several 3rd Party modules. All modules in config.js:

    Remote Control
    Remote Control Repository
    OilTank (just installed this morning, but the error was before)

    Maybe @Jopyth has an idea.

    The odd thing is, that i already installed a Mirror with the exactly same modules and got no error. But this was with Raspbian Stretch lite, now i am using Jessie Desktop. But i cannot imagine that this causes the error

  • @cruunnerr I have just encountered the same error, MM loads on my display BUT i cannot connect to remote-control from a browser. Running stock modules - weather + wunderground, remote-control, remote-control-repository and iFrameReload. Remote access worked fine yesterday before installing iFrame last night. Gonna do some troubleshooting.

  • Moderator

    If it is in this line, then something is wrong when I get the fetch url. Maybe a module without any remote, but it somehow it not caught in the if statemate to catch errors? Maybe the result[0].refs does not necessarily have a fetch url?

Log in to reply