Deutsche Anleitung MagicMirror auf RaspberryPi 3


  • Project Sponsor Module Developer

    @35110

    I don’t use a PIR sensor so I’m not familiar with its installation or any tutorials that might exist. It has been discussed at length on the forum so I suggest doing a forum search. I think you will find the information that you are looking for.

    Ich verwende keinen PIR-Sensor, daher bin ich mit der Installation oder den eventuell vorhandenen Anleitungen nicht vertraut. Es wurde ausführlich im Forum diskutiert, also schlage ich vor, eine Forensuche zu machen. Ich denke, Sie werden die Informationen finden, nach denen Sie suchen.


  • Project Sponsor

    @35110 Hallo 35110

    ich habe auch einen PIR Sensor installiert nach Anleitungen aus diesem Forum, der github Seite von MMM-PIR-Sensor und ein bisschen google-Suche nach der Verdrahtung.
    Da gibt es bei Eingabe von Raspberry Pi PIR eine Menge Ergebnisse.
    Ich kann mich auch an einer deutschen Erklärung versuchen falls es noch keine gibt.

    Ich weiß nicht ob du das Problem oben schon gelöst hast, aber es trat bei mir auf als ich versucht habe per config.txt den OpenGL-Treiber zu aktivieren.
    Das sollte man rückgängig machen und den Treiber (oder den Fake-Treiber) per raspi-config aktivieren. Dann hat es bei mir geklappt.


  • Project Sponsor

    @lavolp3

    Hallo lavolp3, dass wäre sehr hilfreich. Denn ich habe ein PIR Senosor an meinem PI angeschlossen und auch das dazugehörige Modul MMM-PIR Sensor installiert und gemäss der Anleitung angeschlossen. Leider schaltet mein Bildschirm aber nie aus.

    Gruss



  • Hallo @lavolp3 ich würde mich freuen wenn du dieser Deutschen Anleitung deine Erfahrungen zum Modul MMM-PIR-Sensor zusteuerst und damit anderen auch die Chance gibst, sich Ihren Traum vom MagicMirror zu erfüllen.

    Derzeit habe ich xscreensaver auf dem Pi am laufen, so dass der Monitor sich nicht abschaltet. Schöner wäre es in der Tat, wenn er sich automatisch ab bzw. anschaltet, wenn jemand zuhause ist bzw. ihn nutzt.

    Oft versteht man ja die Scripte, wenn man ein fertiges Beispiel sieht. Ich tue mir leider immer sehr schwer mit diesen “Configurations Options” da ich nie weiß wie die in der config.js dann richtig aufgeführt werden müssen.

    Den Fehler habe ich in sofern lösen können, das ich einfach alles neu installiert habe und ganz wichtig…ich habe Node 10 installiert. Seit dem läuft es auch wieder.

    Hat evtl. jemand Erfahrung mit dem Modul MMM-NetworkScanner?? Da hat man ja auch die Möglichkeit, dass der MM sich Ein bzw Abschaltet wenn sich z.B. Mobiltelefone im Netzwerk befinden bzw. es verlassen. Ich habe das zwar schon mal probiert, aber mein MM/PI erkennt keine Geräte im Netzwerk. Config Code kann ich ja mal posten, wenn es von interesse ist.

    Ich freue mich auf jede Hilfe und vor allem Wissensaustausch in der Deutschen Anleitung. DANKE


  • Project Sponsor

    Hi 35110,
    ich habe das NetworkScanner Modul am laufen aber lasse momentan nur anzeigen welches Gerät im Netzwerk ist. Hatte aber keine Probleme bei den EInstellungen.
    Kannst gerne deine config hier oder per PN posten, dann schaue ich sie mir an.

    Zum PIR Modul: Ich werde mich nächste WOche während meines Urlaubs dran setzen.
    Gibt es schon irgendwo ein deutsches Tutorial? Sonst poste ich die Erklärung einfach hier.


  • Project Sponsor

    Also ich habe vor 5min auch gerade das MMM-NetworkScanner installiert. Dieser läuft, wie er sollte mit den MAC Adressen.

    @lavolp3 , ich habe keine deutsche Anleitung gefunden bezüglich dem PIR Sensor. Ich habe einfach das Gefühl, dass mein PIR vielleicht defekt ist. Irgendwo im Internet habe ich eine Anleitung für ein Python Script gefunden, wo man sieht, ob eine Bewegungen erkennt wurde. Das habe ich dann auch so gemacht, aber ich sehe dann im Script keine Bewegung. Spannung habe ich auf dem Kabel, das habe ich gemessen.



  • Ich habe gerade den NetworkScanner erneut eingerichtet bzw. es versucht. Bei mir wird “NO DEVICE ONLINE” auf dem MM angezeigt.

    Habe über den Befehl arp-scan -l -q mal geschaut welche Geräte ArpScan findet und es sind nur LAN Geräte, keine WLAN Geräte 😩

    Anbei mal meinen config:

    {
                            module: "MMM-NetworkScanner",
                            position: "bottom_right",
                            header: "Wer ist daheim",
                            config: {
                                    device: [
                                            { macAddress: "Mac Adresse iPhone", name: "Ich", icon: "mobile"},
                                    ],
                            showUnknown: false,
                            }

  • Project Sponsor

    Das wäre meine config, vielleicht hilft es dir.

    {
            module: 'MMM-NetworkScanner',
            position: 'top_right', 
            config: {
                devices: [
                        { ipAddress: "MAC Adresse", name: "NAS", icon: "globe"},
                        { macAddress: "MAC Adresse", name: "Adri", icon: "mobile"},
    		    { macAddress: "MAC Adresse", name: "Lisa", icon: "mobile"},
                        { macAddress: "MAC Adresse", name: "Desktop", icon: "desktop"},
    		    { macAddress: "MAC Adresse", name: "PI 1", icon: "wifi"},
                        { macAddress: "MAC Adressef", name: "PI 2", icon: "wifi"},
                        { macAddress: "MAC Adresse", name: "PI 3", icon: "wifi"},
                    ],
                showUnknown: false,
                showOffline: true,
                keepAlive: 10,
                updateInterval: 300,
    	    showLastSeen: true
            }        
        },
    


  • Leider nein…selbst wenn ich den PI als Device mit ipAdress angebe, findet MM den Pi nicht…

    Also hab ich evtl. einen Fehler in der Installation…daher nun meine Schritte:

    cd ~/
    sudo apt-get install arp-scan
    cd ~/MagicMirror/modules
    git clone https://github.com/ianperrin/MMM-NetworkScanner.git
    cd ~/MagicMirror/modules/MMM-NetworkScanner
    npm install
    cd ~MagicMirror/config
    nano config.js

    Dort meine derzeitige config:
    {
    module: “MMM-NetworkScanner”,
    position: “bottom_right”,
    header: “Wer ist daheim”,
    config: {
    device: [
    { ipAdress: “192.168.2.120”, name: “PI”, icon: “desktop”},
    { macAddress: “MacAdresse”, name: “Speedport”, icon: “globe”},
    { macAddress: “MacAdresse”, name: “Ich”, icon: “mobile”},
    { macAddress: “MacAdresse”, name: “Frau”, icon: “female”},
    ],
    showUnknown: false,
    showOffline: true,
    keepAlive: 10,
    updateInterval: 300,
    showLastSeen: true
    }

    Update Vendor Database durchgeführt, Befehle wie folgt:
    cd /usr/share/arp-scan
    sudo get-iab -v -u http://standards.ieee.org/develop/regauth/iab/iab.txt
    sudo get-oui -v -u http://standards.ieee.org/develop/regauth/oui/oui.txt

    In der Anleitung steht etwas von “Generatic the Device Array” - ich hab keine Ahnung was das bedeuten soll.


  • Project Sponsor

    Hallo

    Hast du das Wlan eingeschaltet? Wenn ja, kann ich dir auch nicht mehr weiterhelfen. Denn ich beschäftige mich erst seit gut 3 Wochen mit dem Raspberry und beginne bei 0. Für mich ist jeder Tag eine neue Herausforderung auf dem PI 🙂