MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Installing USB Soundcard using seperate USB Mic



  • @e3v3a said in Installing USB Soundcard using seperate USB Mic:

    dtparam=audio=off

    I just tried it. Unfortunately with no luck.
    Sound still comes from the audio jack.



  • I reinstalled the whole system using another SD-card.
    Now I can use the seperate USB-Mic and the audio Out comes from the other USB-Soundcard.
    After that I installed all my modules like MMM-Podcast.
    I played the video and … sound comes from the audio jack again:-(
    However the usb mic and alexa are still working fine. It is just MMM-Podcast which uses the audio jack.
    How can that be? I installed the dependecies especially the omxplayer. But that can´t be the reason, or what do you think?

    lsusb

    Bus 001 Device 004: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller
    Bus 001 Device 005: ID 0d8c:0014 C-Media Electronics, Inc.
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    

    aplay -l

    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: Device_1 [USB Audio Device], Gerät 0: USB Audio [USB Audio]
    
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    

    sudo nano ~/.asoundrc

    pcm.!default {
        type asym
        playback.pcm "plughw:0"
        capture.pcm  "plughw:1"
    }
    
    ctl.!default {
            type hw
            card 0
    }
    

    Do you have an idea? Seems like I am almost there.

    Thanks.


Log in to reply