MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Black screen after MM v2.4.0 update.

  • Did anyone find a fix here? just updated and same thing here. Hopefully i can get this back working tomorrow.

  • Project Sponsor Module Developer


    One way is to go to that link I gave you and download the version you want and install it manually.

  • Bumping this because I’m also having issues. A lot of time on google says it’s not just a MagicMirror issue, but lots of people have problems with the OpenGL drivers. My screen is blanking after some time no matter what, but I also found the hard way that it messes with tvservice (like the Remote Control module uses) – turning my HDMI off straight up insta-shut down my pi! Gonna have to keep researching for sure.

  • I just updated and this is shown at the end of the install.

    MagicMirror installation successful!
    > magicmirror@2.4.1 install-fonts /home/pi/MagicMirror
    > cd fonts && npm install
    npm WARN postcss-html@0.12.0 requires a peer of postcss-less@>=1.1.0 but none was installed.
    npm WARN postcss-html@0.12.0 requires a peer of postcss-scss@>=1.0.0 but none was installed.
    npm WARN postcss-html@0.12.0 requires a peer of sugarss@>=1.0.0 but none was installed.
    npm WARN stylelint-config-standard@16.0.0 requires a peer of stylelint@^7.8.0 but none was installed.
    pi@raspberrypi:~/MagicMirror $

    I applied


    to the config.txt ( also tried with fkms)

    Reboot and I get a black screen.

    When I remove dtoverlay=vc4-kms-v3d then the mirror boots up.
    Any suggestions?

  • @mykle1
    Just found your guide:

    Going at it now and see if it works - thanks for the patience and writing that guide!

  • Project Sponsor Module Developer

    @kastore said in Black screen after MM v2.4.0 update.:

    thanks for the patience and writing that guide!

    You’re welcome, sir. 🙂

  • Got my mirror working again. Had to go over the opengl drivers again and using the fake kms driver did the trick. However one problem remains, i had to also disable the MMM-Pir-Sensor module because that was messing with the system. But also my custom.css is not being used atm, and i cant figure out why its not grabbing it.

  • Anyone else struggling with using MMM-Pir-Sensor after the new update?

  • Yes, I am having the same black screen. I have to disable PIR to be able to use MM at all. I also noted that after I installed PIR I could no longer SSH into the Pi from my desktop computer, whereas I could from my mobile phone. Anyway, the black screen is the main concern right now. I’ll post if I discover anything helpful.

  • Not sure if I’m having the same issue, stupidly updated electron as npm was claiming 1.7.13 had a critical vulnerability (after installing MMM-voice) Then got the backscreen issue. rolled back electron to 1.7.13 & the issue persists.

    Node v9.11.1
    npm 6.1.0

    Thought I’d uploaded the log file but not sure if others can see it. That snippet below is the first error after ALL_MODULES_STARTED

    13:01:19.440 main.js:40 Uncaught TypeError: Cannot read property ‘appendChild’ of undefined
    at main.js:40
    at Array.forEach ()
    at createDomObjects (main.js:24)
    at Object.modulesStarted (main.js:471)
    at startModules (loader.js:59)
    at loader.js:40
    at HTMLLinkElement.stylesheet.onload (loader.js:203)
    (anonymous) @ main.js:40
    createDomObjects @ main.js:24
    modulesStarted @ main.js:471
    startModules @ loader.js:59
    (anonymous) @ loader.js:40
    stylesheet.onload @ loader.js:203

    13:01:20.056 TypeError: Cannot read property ‘getElementsByClassName’ of null
    at moduleNeedsUpdate (main.js:176)
    at main.js:144
    at Promise ()
    at updateDomWithContent (main.js:137)
    at main.js:119
    Promise rejected (async)
    (anonymous) @ main.js:121
    Promise resolved (async)
    (anonymous) @ main.js:118
    updateDom @ main.js:109
    updateDom @ main.js:514
    updateDom @ module.js:358

    Any pointers as to how to get it working again? It was working perfectly before MMM-voice & buggering around with electron.
    Tried a fresh install with the same result 😞

Log in to reply