MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.
READ THE CHANGELOG BEFORE UPDATING!

MMM-voice


  • Project Sponsor Module Developer

    @wjdw87 you can read your way through the installer and install the dependencies manually, only the first step is based on apt-get, maybe the rest is working on a Mac as well, then you can comment out step one and rerun the installer



  • Hello,

    I’m trying the MMM-voice but no luck for now.

    I got “Error” on the Magic mirror and i have the following error in the debug.log :

    INFO: continuous.c(295): Specify '-infile ’ to recognize from file or ‘-inmic yes’ to recognize from microphone.
    ERROR: “cmd_ln.c”, line 641: Duplicate argument name in arguments: -adcdev
    ERROR: “cmd_ln.c”, line 704: Failed to parse arguments list
    INFO: continuous.c(295): Specify '-infile ’ to recognize from file or ‘-inmic yes’ to recognize from microphone.

    And got “12712712712712712712712711111111111111111111” in error.log

    I already tried couple of things :

    • reinstall the module by deleting the node_modules folder and rerun the dependencies.sh script.
    • upgrade everything with apt-get upgrade
    • Configure the usb microphone by creating .asound.rc file

    I’m using a standart usb microphone (http://www.banggood.com/fr/USB-Microphone-For-Raspberry-Pi-p-993726.html)

    I’ve found couple of differents versions how to setup an usb microphone on a RPI3 but no luck either to have a clear sound when i’m recording wav file to test it with following command :

    • arecord -D plughw:1,0 test_mic.wav

    Is there a excellent microphone for RPI3 ?

    Really looking forward to use this module.

    Thanks for your help



  • With @strawberry-3-141 help, thanks again by the way, it’s working now 🙂

    If you got the same issue, here the solution :

    • delete the node_modules folder and then rerun the installer.
    • remove the words.json file on root module folder and restart the magic mirror.
      (It’s going to be regenerated when the module starts)

    That should be it.



  • Hey guys,

    i’ve installed the plugin but getting this error:

    pocketsphinx_continuous: error while loading shared libraries: libpocketsphinx.so.3: cannot open shared object file: No such file or directory

    Any suggestions?


  • Project Sponsor

    @witschi87 Did you follow the installation instructions in the module’s readme.md file? Because it sure looks like you do not have PocketSphinx installed.



  • finally got it work… due to command behavior, all set, but don’t know how it works.
    @strawberry-3-141 is it possible that you could spend time to build a simple music player for MMM-voice module?
    all I need is random play mp3 in a folder, no need to select, just play and stop is OK via voice command.
    thanks in advance.


  • Project Sponsor Module Developer

    We could get Around the issue of @witschi87 but we dont know yet what the problem actually is. When he starts his mirror with DISPLAY=:0 nohup npm start & it works, with pm2 start mm not, but i have seen a couple using it with pm2 already

    @iMAGiC sry I my Time is pretty Limited due to my Bachelor thesis, but i will have a look if i can adjust the Existent Music player to Voice commands easily



  • Hi,

    Some time ago @tyho help me a lot to to use voice commands in the module “Simple music Player” So I can use Start Stop Forward and back. I know in my case snoword hotword Detection was use but maybe it can help. If it was ok for @tyho I can post the code.

    Maybe it will be an option for the first time, till @strawberry-3-141 have more time. 🙂

    Greets gismo



  • Hi, in my case it does not stop blinking and only shows “initialisiere…”

    I tried

        config: {
             microphone: 1,
    

    and

       config: {
             microphone: '1',
    

    but no effect.



  • @DirkS please say " magic mirror" at the first. when it flashing say “voice”, when it changes to Voice mode, you can say command.


Log in to reply