MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

omxplayer overlay



  • For me this works:

    url: '/home/pi/Videos/MoonEclipse.mp4',
    

    So no ‘rtsp:’.
    But I do not know if this sets the right parameters for this purpose, are more suited for CAM streaming I suppose:

    |mm       | Starting stream stream1 with args: [
    1|mm       |     "--avdict",
    1|mm       |     "rtsp_transport:tcp",
    1|mm       |     "--win",
    1|mm       |     "33, 620, 513, 890",
    1|mm       |     "--live",
    1|mm       |     "--video_queue",
    1|mm       |     "4",
    1|mm       |     "--fps",
    1|mm       |     "30",
    1|mm       |     "/home/pi/Videos/MoonEclipse.mp4"
    1|mm       | ]
    

    Makes my Pi very slow too, but that is because I put the file on the SD, which is not a fast medium in my case.



  • ty I will try it

    Ok I tried. Your first config worked perfectly fine when I tried and it showed me the video. However when I just swapped the url with a file path the way you said in your last post the omxplayer does not open it



  • @maxbachmann
    I am just wondering…did you downgrade your electron to avoid activating openGL?
    With openGL activated omxplayer ist not working anymore. Or did I get something wrong.
    Sorry, it is not an answer for your question.

    Thx
    Mr.Coffee



  • Hm no I did not downgrade electron. I am really not that deap in the topic, but why does electron stop omxplayer from working? (at least in my case omxplayer still works, although it kind of does not work with local files for me for whatever reason)



  • @maxbachmann
    Seems like you do not have the latest version of MagicMirror installed.
    It is said “The latest versions of electron use an extreme amount of CPU power when no Open GL driver is loaded. This will result in an overheating Raspberry Pi.”
    Thats why I had to activate OpenGL which stops the omxplayer from working (it is not the electron).
    Enable the Open GL driver to decrease Electron’s CPU usage

    But it is off topic. So thank you so far.



  • wait they screwed electron even more??
    What the heck is wrong with them I am already super annoyed they still use no hardware acceleration for videos



  • To be honest, I do run MM 2.4.1, but did not activate OpenGL. That is to say, I commented out
    #dtoverlay=vc4-fkms-v3d
    The electron processes do not show extreme usage and the temperature is around 48 celsius (25 celsius room temperature).
    I have 2 camera streams running.

    And I fail to see the difference between streaming via a rtsp url and from the SD card.

    It just now pops up in my head; do you have the MPG2 license?
    Try this to see if it is enabled:

    # vcgencmd codec_enabled MPG2
    


  • When not included by default I will definetly do not have it. Will try it when I am home later today.

    And yes I am confused whats the difference aswell. Especially because I can absolutely use omxplayer with a local file from the shell



  • The MPG2 license I most probably needed in order to be able to stream the satellite TS stream.
    With the codec disabled, I am still able to play the .mov and .mp4 files.

    In general the rule applies: when you can play / stream a source using omxplayer from the command-line, you should be able to play that source via MM (as long as the module used passes the right omxplayer parameters).

    If you want to pursue the issue further, you can add the --genlog parameter in order to generate the omxplayer.log file:

    cd /MagicMirror/modules/MMM-RTSPStream
    $ vi node_helper.js
    
    Edit line 113:
    
    args.unshift("--genlog", "--avdict", "rtsp_transport:tcp");
    
    Restart MM.
    
    $ ls -als /home/pi/MagicMirror/omxplayer.log
    

    Perhaps this log will reveal why the file does not play.


Log in to reply