MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

MMM-MirrorMirrorOnTheWall installation issue

  • @OceanK Thank you for respond me. I’m very close! Amazon Developer Console Skill work perfect, Rpi already connect to AWS IoT, but can’t receive any command.
    After very long process work with MirrorMirrorOnTheWall module, I finally got the skill work perfect. When I say “open on the wall”, the Alexa respond to me, and I ask to close all modules, It also respond “Yes my king, closing all Modules”.0_1551445152844_Screenshot (11).png And also, when I “pm2 logs mm” I see “Connected to AWS IoT, Subscribed :MagicMirror: new-text, new-images, change-module, new-video,…”.![0_1551445327440_Screenshot (13).png](Uploading 100%) But for some reason, the command doesn’t make any change in the magicmirror, It look like something stop the exchange data between AWS IoT and Rpi. I read a lot of post but can not find out how to fix that. Does any one have the solution?
    Thank you so much.

  • I have followed the tutorial very closely to get the Alexa skill working but it doesn’t seem to work quite right. Right now my skill will start up and respond accordingly with “Hello my Queen” but when I asked it to display an image it says “there was a problem with requested skills response“.

    When I checked my custom google search it is being hit with my request and it also says there were no errors.

    Does anybody know what I could be missing?

  • @Diep-Trung how did you get the skill to start working? The only thing that seems to work for me is the start up. Any command after that just says “there was a problem with the selected skills response”.

    Thanks for any help

  • All the info is in the thread for this to work

  • @parsons12 I’m at the same point you are. Trying to read through this thread to get a better idea of what I still have to do. I wish someone took the time to compile all the info into a nice doc. Have you figured this out yet? I get the Hello Queen response but then “unable to handle request” error whenever I try to show text, images, etc. I’m working through how to enable google search

  • @sbrundage85 Same Same. Started several months ago, went through this thread and still was not working. Just started to look at it again with a fresh install and go through the thread again. having the same issue. ill post more if i find something. Maybe the more attention we bring back to the thread the bigger the possibility of it getting fixed

  • So after going through the thread again, i am still stuck on the policy issue. i have tried @blackpanda code for the policy change while also changing the client ID to “MagicMirror” on both the pi/MirrorMirrorOnTheWallSkill/src/MirrorMirror.js and pi/MagicMirror/modules/MMM-MirrorMirrorOnTheWall/MirrorMirror.js

    With this i still get Attempt to connect to AWS. my cloudwatch logs show

    2019-07-19T20:27:06.893Z 100e7185-039f-42ce-be95-07ea3a83c847 Task timed out after 3.00 seconds

    which might mean its still a policy security issue or its just not connecting to Iot core.

    When Prompted with intent, Alexa responds with the usual Hello my Queen, but when given a command i continue to get the classic “there was a problem with requested skill response”. Although the logs do show that the youtube video is requested then it times out.

    Any ideas?

  • This post is deleted!

Log in to reply