MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Installing on a Pi Zero

  • @big11

    thats my “achievment” from last night…

    pi@raspberrypi:~ $ cd MagicMirror/
    pi@raspberrypi:~/MagicMirror $ npm start
    > magicmirror@2.6.0 start /home/pi/MagicMirror
    > sh 4: electron: not found
    npm ERR! file sh
    npm ERR! code ELIFECYCLE
    npm ERR! errno ENOENT
    npm ERR! syscall spawn
    npm ERR! magicmirror@2.6.0 start: `sh`
    npm ERR! spawn ENOENT
    npm ERR!
    npm ERR! Failed at the magicmirror@2.6.0 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2019-01-10T07_11_11_053Z-debug.log
    pi@raspberrypi:~/MagicMirror $

  • finally full success!!:)
    @big11 install directly from raspberry terminal not via ssh.
    After few fresh installation and hundreds errors last time tried install using

    bash -c "$(curl -sL"

    from raspberrypi terminal.There were some errors but finally worked.
    if you want, I can make a image of my card and share it.

  • @12wsx

    you made my day…

    it works…

    the first differences i encountered was the Installation of electron …
    this i didn’t found at all the others…

    and i thought before, that this will be the quest…

    regarding to the warnings installing npm

    you could fix that with “npm Audit fix” or “npm Audit fix --force”
    as suggested…

    i did this also, so maybe this could be an error too…

    and if it works but this warnings, who cares…. 🙂

    have a great day…
    thank you

  • Awesome write up. Super helpful!

  • Project Sponsor

    Thank you very much for this work! The tutorial works perfectly. I just installed it in a rpi zero W. Highly recommended for anyone who wants to install it on this SBC.

  • Many thanks Andrew - worked well for me (other than first step: connecting to wifi with WPA2 needed some minor tweaks.)

  • @cdh1001 please specify tweaks as they might help others.

  • @andyc7687 - I needed to delete the line: key_mgmt=WPA-PSK Based on discussions elsewhere I originally tried renaming Key_mgmt to WPA2 and/or changing group=CCMP, but neither of those were necessary for me; simply deleting the line was sufficient.

  • @cdh1001 thanks, I will amend my guide over the weekend then.

  • Thanks for the script and the hints so far 🙂

    Unfortunately I am really frustrated after x installations. 😞 Currently everything is installed the autostart works but chrome says “err_connection_refused”!

    Does anyone have an idea?

    Zero W V1.1 / Raspian Desktop / no sudo

Log in to reply