MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Installing on a Pi Zero

  • Project Sponsor

    @smolo Some suggestions: First, make sure that some form of IP address is present in the address key. Usually, but the IP address of your pi will probably work too. Without that value, the web server has a tendency to freak out.

    Second, make sure you are specifying the port in your web call. That one has bitten me a couple times.

    Third, I would double-check your IP whitelist in the config.js. Possibly open it up to all connections and attempt to view the magic mirror from another computer. See if the problem is local to the PI Zero or if it is on a deeper level.

  • @bhepler
    First, as a supplement the installation is absolute standard except for another VNC server.
    Chromium starts automaticly with http://localhost:8080

    I have already tested the following constellations before my post.
    the local ip (


    with https browser fault > “err_address_unreachable”

    Other things :…

    • ublock is inactive!
    • Configuration vom MagicMirror Config:
      var config = {
      port: 8080,
      address: “”,
      ipWhitelist: [],
    • Test from another pc > “err_connection_refused”

  • I’ve solved the problem and it’s going crazy. After I tried with a portscanner to find out if there is anything running I found out that there is no port 8080 open.

    If somebody has problems checking the logs via "pm2 logs MagicMirror --lines 1000

    I missed the npm module “moment” under “/home/pi/MagicMirror/node_modules/moment”!!!😲

    Go to MagicMirror > “npm install” the problem was solved!🙂

  • @andyc7687, thanks a lot! It will be easy for me now, I planned going for building a device like yours

  • @analogcheep thanks, let me know if yours works and upvote if it is helpful!

  • today i have to reinstall MM and I have some small problem. MM do not show on local hdmi outpul- I can see the dektop but no MM. Server is working properly because when I open it from laptop i can see MM, when I connect to raspberry pi via vnc i can see to MM. What is going on? what i miss?

  • @12wsx in terminal, or script u use to start mm do

    export DISPLAY=:0

    Then npm start

  • thank you for help, i had to reinstal system once more becase there were a lot of errors.
    After new instalation pm2 didn’t start properly. after few hours i found why.
    In pm2_MagicMirrorPi0.json
    “script” : “/MagicMirror/PiZero/”,
    should be :
    “script” : “/MagicMirror/PiZero/”,

  • which installer are you using? I don’t see the filename pm2_MagicMirrorPi0.json
    or “script” : “/MagicMirror/PiZero/”,
    in the script…

  • ah, ok… i see you followed the manual instructions back a few posts…

    i have a modified I have for testing, that takes user into account

    to use it like normal

    bash -c “$(curl -sL”

Log in to reply