MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-Pollen and MMM-Quote of the day



  • Hello,
    I am having issues with both of the above modules. When I add them to the config/config.js file, my MM gives the error message about no config file. if I delete those lines, it goes back to working correctly. I am certain I am the one making a mistake, but I cannot figure it out. I am not a programmer or coder–just dabbling with the Pi. I have even just copied the maker’s code without adjusting for my location, and it still fails. Please help if you can.

    },
                   {
                           module: "MMM-Pollen",
                           position: "top_left",
                           header: "Pollen Forecast",
                           config: {
                                   updateInterval: 3 * 60 * 60 * 1000, // every 3 hours
                                   zip_code: "90210"
                           }
                    },
                    {
                        module: "MMM-quote-of-the-day",
                        position: "lower_third",
                        config: {
                            language: "en",
                            updateInterval: "1d"
                    	}
                    }
    
    


  • @twwilkerson1 add this to my issue as well. Clearly I am bad at this. I get the same “no config file” error message when I tried to add the MMM-PIR-Sensor to my config/config.js file.

    //your code here
    ```               {
                            module: 'MMM-PIR-Sensor',
                            config: {
                                    sensorPin: 17,
                                    powerSaving: true // See 'Configuration options' for more information.
                    },
            }
            ]
    
    };
    
    

    Any advice is greatly appreciated.


  • Project Sponsor Module Developer

    @twwilkerson1

    You’re missing a comma at the end of the “MMM-quote-of-the-day” entry and there is a comma out of place in the sensor entry. Everything else looks good. Try these please.

    {
        module: "MMM-Pollen",
        position: "top_left",
        header: "Pollen Forecast",
        config: {
            updateInterval: 3 * 60 * 60 * 1000, // every 3 hours
            zip_code: "90210"
        }
    },
    {
        module: "MMM-quote-of-the-day",
        position: "lower_third",
        config: {
            language: "en",
            updateInterval: "1d"
        }
    },
    {
        module: 'MMM-PIR-Sensor',
        config: {
            sensorPin: 17,
            powerSaving: true // See 'Configuration options' for more information.
        }
    },
    

Log in to reply