MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Looking for beta testers for MMM-Remote-Control



  • @Jopyth The console messages are from the pm2 logs…
    I run MM as the default user (pi) and didn’t set any special rights for any folders or files…
    Now that you mention it, it could be that the saving of the shown/hidden modules didn’t work before either.

    BTW: I’m running MM on a Pi Zero (so using ‘serveronly’).

    Edit: now that I think about it: I do have a HelloWorld module enabled which already used single and double quotes before. So maybe there’s a conflict with the added quotes. I will look in to this this weekend.



  • @Jopyth is there a possibility to include system updates in the remote ? ie “apt dist-upgrade” or whatever subsystem thats used on the system.


  • Moderator

    @rvdgeer Would be great to find out what causes this and hopefully fix it, however it is still not clear to me, what the reason is. I will investigate a little bit more on the weekend. Maybe I am able to reproduce the issues, could you post your node --version?

    In the meantime you could compare your config.js and the config.js.backupX and see if you find possible differences?



  • This morning (CET) I have a little more time to do bug reports, troubleshoot and answer some of your questions.
    So, first things first.

    My node version:
    v6.8.1

    About the config backups:
    I noticed the that the double quotes were added to the keys and values before the backup was made.
    This means I don’t have a backup of the true original.
    It also means I can only compare the current config file to the backup and not the the original.

    Another thing I noticed is that backupfile got overwritten this morning.
    Because my MagicMirror is still a work in progress it’s powered off most of the time.
    When I tried to reproduce the issues I came across last time I noticed that the first backup I made was saved as config.js.backup1, overwriting a previous backup.
    At least for me this wasn;t expected behaviour and I don’t think it’s how I wish to save (or lose) my backups.

    About saving hidden/shown modules:
    As I said before, I haven’t set any special permisions and I’m using the default useron my Pi Zero: pi
    Becasue there’s no keyboard and mouse attached (the Pi Zero’s micro usb port is used for a wifi dongle) I use ssh and scp (and of cource the Remote!) to do most editing, testing and troubleshooting.
    On saving the current state of hidden/shown modules the pm2 logs reported this:
    On hiding the helloworld module:

    0|mm       | ** Message: console message: http://localhost:8080/modules/MMM-Remote-Control//MMM-Remote-Control.js @219: [object Object]
    0|mm       | ** Message: console message: http://localhost:8080/js/logger.js @20: helloworld is suspended.
    0|mm       | ** Message: console message: http://localhost:8080/js/module.js @313: TypeError: Object is not a function (evaluating 'callback()')
    

    On saving the current state directly after:

    0|mm       | ** Message: console message: http://localhost:8080/modules/MMM-Remote-Control//MMM-Remote-Control.js @219: [object Object]
    0|mm       | Whoops! There was an uncaught exception...
    0|mm       | { Error: EACCES: permission denied, open '/home/pi/MagicMirror/modules/MMM-Remote-Control/settings.json'
    0|mm       |     at Error (native)
    0|mm       |   errno: -13,
    0|mm       |   code: 'EACCES',
    0|mm       |   syscall: 'open',
    0|mm       |   path: '/home/pi/MagicMirror/modules/MMM-Remote-Control/settings.json' }
    0|mm       | MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    0|mm       | If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    

    This can be reproduced every time when I follow these steps.
    I you need any specific testing, please let me know and I’ll try to find the time.



  • And one more.
    On restarting I get the following error:

    0|mm       | { Error: Command failed: pm2 restart mm
    0|mm       |     at ChildProcess.exithandler (child_process.js:206:12)
    0|mm       |     at emitTwo (events.js:106:13)
    0|mm       |     at ChildProcess.emit (events.js:191:7)
    0|mm       |     at maybeClose (internal/child_process.js:877:16)
    0|mm       |     at Socket. (internal/child_process.js:334:11)
    0|mm       |     at emitOne (events.js:96:13)
    0|mm       |     at Socket.emit (events.js:188:7)
    0|mm       |     at Pipe._handle.close [as _onclose] (net.js:498:12)
    0|mm       |   killed: true,
    0|mm       |   code: null,
    0|mm       |   signal: 'SIGTERM',
    0|mm       |   cmd: 'pm2 restart mm' }
    0|mm       | Loading config ...
    0|mm       | Loading module helpers ...
    0|mm       | No helper found for module: helloworld.
    0|mm       | No helper found for module: alert.
    0|mm       | Initializing new module helper ...
    0|mm       | No helper found for module: clock.
    0|mm       | Initializing new module helper ...
    0|mm       | Initializing new module helper ...
    0|mm       | No helper found for module: currentweather.
    0|mm       | No helper found for module: weatherforecast.
    0|mm       | Initializing new module helper ...
    0|mm       | No helper found for module: compliments.
    0|mm       | Initializing new module helper ...
    0|mm       | All module helpers loaded.
    0|mm       | Starting server op port 8080 ...
    0|mm       | Server started ...
    0|mm       | Connecting socket for: MMM-Remote-Control
    0|mm       | Starting node helper for: MMM-Remote-Control
    0|mm       | Connecting socket for: MMM-Traffic
    0|mm       | MMM-Traffic helper started ...
    0|mm       | Connecting socket for: calendar
    0|mm       | Starting node helper for: calendar
    0|mm       | Connecting socket for: MMM-NetworkScanner
    0|mm       | Starting module: MMM-NetworkScanner
    0|mm       | Connecting socket for: newsfeed
    0|mm       | Starting module: newsfeed
    0|mm       | Sockets connected & modules started ...
    0|mm       | Ready to go! Please point your browser to: http://localhost:8080
    


  • Is there any new version to test?


  • Moderator

    @done Kind of, yes. I think I have not fixed all mentioned errors, but hopefully the major ones. Also @Mr-Meeseeks added some new functionality (sending alerts).

    Feel free to git pull the current status and test again. 🙂 It should no longer mess up config.js files as much, but it still could be. It is using config.js.backupX so make manual backup somewhere else.



  • @rvdgeer do you have pm2 installed and configured? Oh looked above, you do. Well I have noticed even though logs show command error, it still works, I think it’s because node doesn’t surround commands in quotes.