MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.
READ THE CHANGELOG BEFORE UPDATING!

MM2 my first try



  • it seems good, better than i used to think

    but i 've got a few problem with forecast weather module
    i cant see the predicted amount of rain.
    i set up the option by true and it dont changes anythinks

    second problem :
    i set up “colored” in true but
    instead of having max and min temperature
    i’ve got max and gap :
    max temp is in red and gap is in blue

    that sucks

    any ideas ?



  • @seramik You can find the problem inside the modules by using the Developer tools. Acces this by using the shortcut ctrl + shift + i. When you have the developer tools open you can inspect elements and figure out errors by reading the console log and or relevant code for the element. There is so much more information there though 😉

    This really important tool will help you so much with fixing problems inside your MagicMirror. What also will help you is this forum and knowledge you gather. Good luck with figuring out your 2 problems! If you have more questions do ask!



  • true, no rain prediction, cauz of type of account on meteo site, i read it

    for temp max and temp min, it seems to be an actual trouble,
    TY for the tips, i’ve already found the proper section, where i 'll have to ask my question



  • I helped a friend do a setup, we used :

    The initial script failed on dependancies and depracated packages. Just could not get it to work.

    Today I followed the instructions on :

    While I did get warnings, everything worked like a charm ( well - more or less - I forgot to copy the config.)

    I know from another package ( https://octoprint.org/ - The OctoPi ) that some work needed to be done to support the RPi 3 B+ (Newer CPU ? Drivers ? Chipsets? - no really sure). Could this be the issue?

    I will borrow his RPi 3 B+ and try again next week if no one else has comparables.


  • Project Sponsor

    @alainchiasson said in MM2 my first try:

    The initial script failed on dependancies and depracated packages. Just could not get it to work.

    The installation script hasn’t been updated to handle some of the changes in the latest version of Raspbian. I would ignore it and follow the steps for a manual installation.





  • I too had the same problem with my attempt at installing the MM program. I found this on
    https://www.w3schools.com/nodejs/nodejs_raspberrypi.asp. i used it as a long shot as i was running out of things to try. it worked and i now have MM up and running. I am using the AIY project file as install on raspberry pi 2.



  • so second try : i decided to restart from the beginning
    i tried the manual installation
    first i install the node .js, no trouble, intall seems OK
    but when i began " npm install && npm start", troubles appear :

    pi@raspberrypi:~/MagicMirror $ npm install && npm start
    npm WARN deprecated time-grunt@2.0.0: Deprecated because Grunt is practically unmaintained. Move on to something better. This package will continue to work with Grunt v1, but it will not receive any updates.
    npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.

    electron-chromedriver@1.8.0 install /home/pi/MagicMirror/node_modules/electron-chromedriver
    node ./download-chromedriver.js
    

    successfully dowloaded and extracted!

    electron@2.0.16 postinstall /home/pi/MagicMirror/node_modules/electron
    node install.js
    

    Downloading SHASUMS256.txt
    [============================================>] 100.0% of 5.39 kB (5.39 kB/s)

    magicmirror@2.6.0 install /home/pi/MagicMirror
    cd vendor && npm install
    

    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“arm”})

    added 82 packages from 57 contributors and audited 220 packages in 15.75s
    found 4 low severity vulnerabilities
    run npm audit fix to fix them, or npm audit for details

    magicmirror@2.6.0 postinstall /home/pi/MagicMirror
    sh installers/postinstall/postinstall.sh && npm run install-fonts
    

    MagicMirror installation successful!

    magicmirror@2.6.0 install-fonts /home/pi/MagicMirror
    cd fonts && npm install
    

    added 1 package from 1 contributor and audited 1 package in 8.517s
    found 0 vulnerabilities

    npm WARN grunt-stylelint@0.10.1 requires a peer of stylelint@^9.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself.

    added 930 packages from 1367 contributors and audited 2433 packages in 210.933s
    found 23 vulnerabilities (8 low, 14 moderate, 1 high)
    run npm audit fix to fix them, or npm audit for details

    magicmirror@2.6.0 start /home/pi/MagicMirror
    sh run-start.sh
    

    Starting MagicMirror: v2.6.0
    Loading config …
    WARNING! Could not find config file. Please create one. Starting with default configuration.
    Loading module helpers …
    Initializing new module helper …
    Module helper loaded: updatenotification
    No helper found for module: helloworld.
    All module helpers loaded.
    Starting server on port 8080 …
    Server started …
    Connecting socket for: updatenotification
    Sockets connected & modules started …
    Launching application.
    Shutting down server…
    Stopping module helper: updatenotification

    so, as resquest, i run npm audit for fixthis

    pi@raspberrypi:~/MagicMirror $ npm audit fix
    npm WARN acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN grunt-stylelint@0.10.1 requires a peer of stylelint@^9.0.0 but none is installed. You must install peer dependencies yourself.

    jshint@2.10.1
    added 4 packages from 4 contributors, removed 7 packages and updated 13 packages in 44.656s
    fixed 13 of 23 vulnerabilities in 2433 scanned packages
    2 vulnerabilities required manual review and could not be updated
    1 package update for 8 vulns involved breaking changes
    (use npm audit fix --force to install breaking changes; or refer to npm audit for steps to fix these manually)
    pi@raspberrypi:~/MagicMirror $
    

    and i still have thoses 2 warnings who seems bad


  • Project Sponsor

    @seramik - Warnings are just that: warnings. I usually ignore them and concentrate on errors. Errors will prevent your mirror from working.

    This, OTOH, is important:

    WARNING! Could not find config file. Please create one. Starting with default configuration.

    To fix this, you need to copy the included sample configuration file to its final destination. This will become your working configuration file and what you will edit as you add modules.

    cd ~/MagicMirror/config
    cp config.js.sample config.js
    

    So now when you want to change the behavior of your mirror, you will edit the config.js file.



  • it is OK for the config file, i’ve got the old one


Log in to reply