MMM-GoogleFit



  • I just whipped up a google fit module this weekend for personal use, but thought the wonderful community would appreciate it as well! Currently it will show your step progress as well as weights if you record those.

    Check it out on github and give any feedback you have. I made this for my own personal needs, but am open for feedback 🙂

    Cheers!

    Colored rings screenshot

    https://github.com/amcolash/MMM-GoogleFit



  • Pretty nice!



  • Someone else was running a pi zero and noticed issues with the authentication flow. Please make an issue on github or leave a comment here if you have any problems!



  • Nice work. Do you know if it’d handle two instances - i.e. two google accounts? I can imagine some friendly competition in my house with this!



  • I have not played around with multiple instances of a MM module, but I can take a look into it when I get some time this weekend. There are some assumptions that are made right now that prevent multiple instances from accessing different accounts. That being said, I am not sure how much work it would take to do but I am up for at least investigating this.



  • That’d be awesome! I hope it’s straightforward. Also, I’m using it currently on a pi zero W and had no issues with the authentication process. Cheers.



  • @nitram, I made a github issue based off of your feedback - check for updates there 🙂

    https://github.com/amcolash/MMM-GoogleFit/issues/3



  • @amcolash Amazing!! Thanks so much. This all worked perfectly for me, with the exception that I also needed to rename the MMM-GoogleFit.js file in the second instance’s directory to MMM-GoogleFit2.js - nothing happened otherwise. I also took the opportunity to change the innerhtml content in that file to something more distinctive for each instance and now we can all see our steps. Super happy with this - even the wife thinks its good now!



  • @nitram So glad to hear that things worked out smoothly - yeah forgot about renaming the file - sorry about that. Glad that you and your wife are liking this module! Cheers



  • I’m getting an auth error, “stats error”. I’ve followed the steps and MMM-GoogleFit shows up in my google apps with permissions. Any ideas?

    Edit: Update, The issue has resolved without me doing anything different so I’m not quite sure what the issue was but the module is working great. Thank you for this!