MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Default calendar module stopped showing iCloud events



  • After working correct (Raspberry Pi 3B) for several months the calendar module stopped displaying events from my iCloud calendar a few days ago and shows no events. There are many events within my iCloud calender and they are still visable on https://www.icloud.com/#calendar. The public webcal URL in config.js is unchanged and matches with iCloud public URL generated online by Apple. Newsfeeds and weather forecast works fine so I can exclude network issues. Please see my calendar config below. Are there issues with the module or iCloud? Any suggestions to solve this?

            {
                    module: "calendar",
                    header: "Agenda",
                    position: "top_left",
                    config: {
                            fade: false,
                            maximumEntries: 7,
                            displaySymbol: false,
                            calendars: [
                                    {
                                            symbol: "calendar-check-o ",
                                            url: "webcal://p01-calendarws.icloud.com/ca/subscribe/1/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
                                   }
                            ]
                    }
            },


  • I had the same issue from last Monday. I was using the calendar for about 1 month (newby MagicMirror). I checked everything and as it seems nothing had changed, but get keeping “No upcoming events”.

    Then I created a new calendar and made it public. What I saw is that the URL was quite different from the one I used. I see the same with you.

    old: webcal://p01-calendarws.icloud.com/ca/subscribe/1/
    new:webcal://p40-calendars.icloud.com/published/2/

    I openend my calendar on my Macbook and set the published option off for my calendar. Than I put it back on and got a new URL with the same ‘new’ format. I put this in my MagicMirror config and everything works again (now for 1 week already).

    I hope this is the solution for your problem also…Succes!



  • Following your steps it turned out you’re right, thanks for helping! All my iCloud events are back on the mirror. I did not create a complete new calendar, I only unchecked and thereafter checked “make public” and copied the new URL : webcal://p41-calendars.icloud.com/published/2/… in the config.js file.

    Again many thanks for your fast reply.



  • I didn’t create a new calendar, only for testing purposes. After finding out what the possible issue was, I’ve unchecked and thereafter checked “make public” and copied the new URL.

    Great it works for you too!! 👍🏼



  • @MM-Hans can u mark your issue resolved please


Log in to reply