MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

Unable to install MMM-RTSPStream due to missing dependencies



  • Hello,

    I was trying to install MMM-RTSPStream today and npm fails everytime with ecstatic dependency not met:

    pi@mdr-mm:~/MagicMirror/modules/MMM-RTSPStream $ npm install
    npm WARN deprecated datauri@1.1.0: Datauri 2.0 released. See more in https://github.com/data-uri/datauri/releases/tag/v2.0.0
    npm WARN deprecated mimer@0.3.2: Mimer 1.0 released. See more in https://github.com/data-uri/mimer/releases/tag/v1.0.0

    MMM-RTSPStream@1.2.2 postinstall /home/pi/MagicMirror/modules/MMM-RTSPStream
    sudo npm i -g http-server

    npm ERR! code ETARGET
    npm ERR! notarget No matching version found for ecstatic@^3.0.0
    npm ERR! notarget In most cases you or one of your dependencies are requesting
    npm ERR! notarget a package version that doesn’t exist.
    npm ERR! notarget
    npm ERR! notarget It was specified as a dependency of ‘http-server’
    npm ERR! notarget

    npm ERR! A complete log of this run can be found in:
    npm ERR! /root/.npm/_logs/2019-05-02T21_57_30_835Z-debug.log
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! MMM-RTSPStream@1.2.2 postinstall: sudo npm i -g http-server
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the MMM-RTSPStream@1.2.2 postinstall script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR! /home/pi/.npm/_logs/2019-05-02T21_57_31_267Z-debug.log

    I found out that ecstatic 3.x.x was removed and only version 4.1.2 exists, leaving me unable to install http-server:

    pi@mdr-mm:~ $ npm view ecstatic versions --json
    [
    “4.1.2”
    ]

    @shbatm , it it possible for you to update your code to overcome this problem?

    Regards,

    Bruno