MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Need some help getting AlexaOnOff to work with Google Mini



  • @shbatm
    Need some help getting AlexaOnOff to work with Google Mini

    I’m including the following folks in this post since, at some point in the forum, they have all asked how to get AlexaOnOff working with Google Home @eddgeywing @retroflex @selarp @felipemfa
    If any of you have already gotten Google to work with AlexOnOff, please share.

    @shbatm in previous posts you asked for the following info so here it is:

    1. My mirror version is 2.7.1. My understanding is I don’t need to change line 21 in MMM-AlexaOnOff to match this number.
    2. “FauxMo service started. Listening on 192.168.1.32:21900” is listed – see below.
    3. Tested with example but got similar results as original – see below.
    4. Even tried discovery from alexa.amazon.com but unable to register for account since I don’t have an echo – yes, I’m desperate…

    Here is the code for my config.js – should be same as yours:

    {
        			module: 'MMM-OnScreenMenu',
        			position: 'bottom_right',
    		},
    		{
        			module: 'MMM-AlexaOnOff',
        			config: {
            			devices: [{ 
                  			name: "Magic Mirror",
                  			on: { 
                    			notification: "ONSCREENMENU_PROCESS_ACTION",
                    			payload: { actionName:'monitorOn' }
                  			},
                  			off: { 
                    			notification: "ONSCREENMENU_PROCESS_ACTION",
                    			payload: { actionName:'monitorOff' }
                  			},
            		}]
        			}
    		},
    

    Here is what I get when I start MagicMirror:

    pi@raspberrypi:~ $ cd MagicMirror
    pi@raspberrypi:~/MagicMirror $ sudo npm start
    
    > magicmirror@2.7.1 start /home/pi/MagicMirror
    > sh run-start.sh
    
    Starting MagicMirror: v2.7.1
    Loading config ...
    Loading module helpers ...
    No helper found for module: clock.
    Initializing new module helper ...
    Module helper loaded: calendar
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    No helper found for module: MMM-google-route.
    Initializing new module helper ...
    Module helper loaded: MMM-OnScreenMenu
    Initializing new module helper ...
    Module helper loaded: MMM-AlexaOnOff
    All module helpers loaded.
    Starting server on port 8080 ... 
    Server started ...
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: MMM-OnScreenMenu
    Connecting socket for: MMM-AlexaOnOff
    Module helper started for MMM-AlexaOnOff
    Sockets connected & modules started ...
    Launching application.
    Create new calendar fetcher for url: https://calendar.google.com/calendar/ical/xxx/basic.ics - Interval: 300000
    21900
    FauxMo service started. Listening on 192.168.1.32:21900
    

    Here is the sudo netstat -tulpn:

    pi@raspberrypi:~ $ sudo netstat -tulpn
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
    tcp        0      0 127.0.0.1:8080          0.0.0.0:*               LISTEN      3081/electron       
    tcp        0      0 0.0.0.0:21900           0.0.0.0:*               LISTEN      3081/electron       
    udp        0      0 0.0.0.0:1900            0.0.0.0:*                           3081/electron       
    udp        0      0 0.0.0.0:68              0.0.0.0:*                           307/dhcpcd          
    udp        0      0 0.0.0.0:56022           0.0.0.0:*                           335/avahi-daemon: r 
    udp        0      0 224.0.0.251:5353        0.0.0.0:*                           1334/libpepflashpla 
    udp        0      0 224.0.0.251:5353        0.0.0.0:*                           1334/libpepflashpla 
    udp        0      0 0.0.0.0:5353            0.0.0.0:*                           335/avahi-daemon: r 
    udp6       0      0 :::55455                :::*                                335/avahi-daemon: r 
    udp6       0      0 :::5353                 :::*                                335/avahi-daemon: r 
    pi@raspberrypi:~ $ 
    

    And starting the example:

    pi@raspberrypi:~ $ cd ~/MagicMirror/modules/MMM-AlexaOnOff/node_modules/fauxmojs/example
    pi@raspberrypi:~/MagicMirror/modules/MMM-AlexaOnOff/node_modules/fauxmojs/example $     node example.js
    started..
    

    And the sudo netstat -tulpn for the example:

    pi@raspberrypi:~ $ sudo netstat -tulpn
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
    tcp        0      0 127.0.0.1:8080          0.0.0.0:*               LISTEN      3081/electron       
    tcp        0      0 0.0.0.0:11000           0.0.0.0:*               LISTEN      3634/node           
    tcp        0      0 0.0.0.0:11001           0.0.0.0:*               LISTEN      3634/node           
    tcp        0      0 0.0.0.0:21900           0.0.0.0:*               LISTEN      3081/electron       
    udp        0      0 0.0.0.0:1900            0.0.0.0:*                           3634/node           
    udp        0      0 0.0.0.0:1900            0.0.0.0:*                           3081/electron       
    udp        0      0 0.0.0.0:68              0.0.0.0:*                           307/dhcpcd          
    udp        0      0 0.0.0.0:56022           0.0.0.0:*                           335/avahi-daemon: r 
    udp        0      0 224.0.0.251:5353        0.0.0.0:*                           1334/libpepflashpla 
    udp        0      0 224.0.0.251:5353        0.0.0.0:*                           1334/libpepflashpla 
    udp        0      0 0.0.0.0:5353            0.0.0.0:*                           335/avahi-daemon: r 
    udp6       0      0 :::55455                :::*                                335/avahi-daemon: r 
    udp6       0      0 :::5353                 :::*                                335/avahi-daemon: r 
    pi@raspberrypi:~ $ 
    

    Switching gears –
    I started looking at the Belkin website for how to connect Wemo to Google:
    https://www.belkin.com/us/support-article?articlenum=224185

    The article basically says that you have to setup your Wemo device before Google can find it. In order to setup your Wemo device, you have to select it from your wifi menu:
    https://www.belkin.com/us/support-article?articlenum=110936

    After running Mirror (and same with example), I tried setting up Wemo but I’m not able to see the faux Wemo switch or devices on my wifi.

    Is the faux Wemo discoverable under wifi as the article directs?

    Another option Belkin describes is entering the MAC address.
    Is there a MAC address for the faux Wemo switch?

    I know that’s a lot of stuff to go through but I’ve been working on this for a while.
    I really want to get this working. Without it, my mirror is pretty much useless.
    I’m going to use AlexaOnOff with OnScreenMenu to turn the monitor on and off only (BTW – OnScreenMenu works great, thanks).

    Any help with AlexaOnOff would be appreciated.

    Thanks,
    Scott



  • @smackenzie5 said in Need some help getting AlexaOnOff to work with Google Mini:

    @shbatm

    @shbatm
    According to this article, Google home runs port 80:
    https://github.com/makermusings/fauxmo/issues/21

    Don’t know if that would make a difference?

    Thanks


Log in to reply