MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

screen rotation - display cropped



  • Hi guys…

    I just managed to install MagicMirror² v2.8.0.

    I had to

    sudo nano /boot/config.txt
    display_rotate=3
    

    in order to rotate the display in a human readable orientation.

    While booting screen rotation just displays every line and takes the whole screen as needed. After booting finished and modules are showing up, I unfortunately get a cropped screen. It just looks like I see the modules in width half way cropped (I see some “hi sexy” with the letter y already cropped off).

    I can’t find any information on how to solve this, so any help would be greatly appreciated!

    Thanks!

    Regards
    Corben



  • Now get loaded of this:
    Although PM2 is configured to reload on each config.js change, I restarted the machine like a jillion times now (I’m almost sure about that number). But on one restart it showed me a rainbow screen first off (although I told it via configuration not to) and if it wasn’t strange enough, it showed me the LXDE-GUI desktop for some seconds (somewhat foreseeable). And here is the kicker: Afterwards it loaded the mirror showing everything aok (nice resolution, everything in place and correctly rotated).
    As I couldn’t belive it, I restarted the machine right away to see if it magically stays like this… and it doesn’t. 😖



  • Do you have an entry in your config for dtoverlay?

    #Enable the Open GL driver to decrease Electron’s CPU usage
    dtoverlay=vc4-fkms-v3d

    if so, look in the following file for a rotate entry. It and the rotate added to config.txt may be conflicting.
    ~/.config/lxsession/LXDE-pi/autostart

    #to rotate display, to rotate left, use left.
    @xrandr --output HDMI-1 --rotate right



  • Yes I have. This dtoverlay entry for fake kms is like default on Raspbian Buster (on Rasperry Pi 4).

    But now that you mention it, I most probably was pretty confused by this guide over here:
    Configuring-the-Raspberry-Pi

    Following it I thought it would be good enough for fake kms to put the

    display_rotate=3
    

    in config.txt (as stated in my first post), but after disabling it (this is crucial!) and putting your suggestion about the xrandr option in autostart it finally worked in the end.

    “In the end”, as I would really like it to be always rotated (including boot), but hey… this is something to work with.

    Cheers!

    -Corben


Log in to reply