MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Cannot Get Magic Mirror To Start On Second Screen



  • Hello, I recently bought a raspberry pi4b 4Gig model and found this application. I love Magic Mirror and have been playing it for a week now. But I want magic mirror to start on the second screen (official Raspberry Pi 7" touchscreen) instead of it’s main screen (a 55" Smart TV). I already tried the electionOption, but that resolves into an error for the config file. I already set some config files from magic mirror to start from screen 4 (That’t the official screen for the LCD display, where screen 0 is my default screen). But that even doesn’t work. Anyone know how to let MagicMirror start from the second screen? I would be very happy if someone knows how to fix this.



  • @djdadevil great!.. thanks for the feedback… Not Dutch, US…

    can u mark your issue resolved? click the 3 dots to the right



  • @djdadevil

    so, in MagicMirror/installers/mm.sh you edited DISPLAY=:0 to DISPLAY=:4 right?

    Assuming u are using pm2 to start MM…



  • yes that’s exactly what I did, and yes I used pm2 to autostart, but disabled it so now i start with npm start inside MagicMirror folder from terminal. Intention is to let it start with pm2 autostart if i can get it to start on that second screen.



  • @djdadeviland using npm start you do

    export DISPLAY=:4
    

    beforehand…

    do u have two independent displays or one big one?
    (all my dual monitor setups have been one big virtual screen)



  • Maybe to clarify it a bit more: I have my big screen on HDMI port 1 from my raspberry pi. I did connect the 7" touchscreen with de monitor port on the raspberry itself, not through it’s HDMI port 2 or otherwise. And ok, the export worked but now it says it can’t connect to screen 4, but there is an extended desktop on that screen. That’s kinda weird. I don’t know anything else right now…



  • @djdadevil i think extended desktop disables independent display…

    i don’t think u can make MM show up on the right side of a large extended display. without changing the css for screen size



  • That is what the electron option in the config file should do:

    electronOptions: {fullsscreen:false, width:800, x:600}
    

    But this gave an error when starting the MagicMirror app.
    And i know CSS, there isn’t anything in main.css wich states what the resolution schould be, only that everything must stretch to 100%. Than modules can overlap eachother, but that is what I can edit in the config file and modules own css files.



  • @djdadevil said in Cannot Get Magic Mirror To Start On Second Screen:

    electronOptions: {fullsscreen:false, width:800, x:600}

    	electronOptions: {fullscreen:false, width:800, x:600},
    

    two things…
    1- need comma at the end
    2 - u had TWO ‘s’, fullsscreen:false

    changed as above and it sets position correctly



  • Wauw Thanks! Now it work’s! I’ve got the comma, but the two fullscreens i dit not. You really made my day today! Now it’s a window wich I can place on the second screen. Really thank you very much, and don’t know if you are Dutch to (Like Michael Teeuws the creator of this is), but great help man! You solved my problem! Your’s sincerrely!



  • @djdadevil great!.. thanks for the feedback… Not Dutch, US…

    can u mark your issue resolved? click the 3 dots to the right


Log in to reply