MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MagicMirror Newsfeed continually "loading"...



  • Apologies for creating another topic about this. I have done loads of research and have read all of the old topics, but cannot get past this.

    I’m totally new to this sort of this and thought that this looked nice and easy having viewed a few guides and watched a few videos. I was wrong.

    Long story short, I have a fairly fresh install of MM and cannot get the newsfeed to work at all. I’ve left it default and it doesnt populate; I’ve tried to change it to the BBC UK feed (my preferred feed btw) but again it just says “Loading…” along the bottom bar.
    I’ve tried so many different variations of the code in the config (but end up breaking it everytime and having to revert it to a saved config file), as well as changing (and reverting to default) all of the other .js files within the newsfeed folder.

    I have pasted my current config.js below, any help would be greatly appreciated. Also, please note, I’m a massive noob and very simple.

    Once I crack this it’ll be onto the next big problem regarding the assistant… but that a fight for another day. The most important thing right now is a functional MM with a newsfeed!

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     *
     * For more information how you can configurate this file
     * See https://github.com/MichMich/MagicMirror#configuration
     *
     */
    
    var config = {
    	address: "localhost", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	language: "en",
    	timeFormat: 24,
    	units: "metric",
    
    	modules: [
    		{
    			module: "alert",
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			module: "clock",
    			position: "top_left"
    		},		
    		{
    			module: "compliments",
    			position: "lower_third"
    		},
    		{
    			module: "currentweather",
    			position: "top_right",
    			config: {
    				location: "Chessington",
    				locationID: "2653229",  //ID from http://bulk.openweathermap.org/sample/; unzip the gz file and find your city
    				appid: "DELIBERATELY BLANK"
    			}
    		},
    		{
    			module: "weatherforecast",
    			position: "top_right",
    			header: "Weather Forecast",
    			config: {
    				location: "Chessington",
    				locationID: "2653229",  //ID from http://www.openweathermap.org/help/city_list.txt
    				appid: "DELIBERATELY BLANK"
    			}
    		},
    		{
    			module: "newsfeed",
    			position: "bottom_bar",
    			config: {
    				feeds: [
    					{
    						title: "New York Times",
    						url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
    
    					}
    				],
    				showSourceTitle: true,
    				showPublishDate: true,
    			}
    		},
    		{
    			module: "MMM-Hotword",
    			config: {
    				record: {
    					recordProgram : "arecord",  
    					device        : "plughw:1"
    				},
    				autostart:true,
    				onDetected: {
    					notification: (payload) => {
    					return "ASSISTANT_ACTIVATE"
    					},
    					payload: (payload) => {
    						return {
    						  profile: payload.hotword
    						}
    					}
    				},
    			},
    		},
    		{
    			module: "MMM-AssistantMk2",
    			position: "top_right",
    			config: {
    				deviceLocation: {
    					coordinates: { // set the latitude and longitude of the device to get localized information like weather or time. (ref. mygeoposition.com)
    					latitude: 37.5650168, // -90.0 - +90.0
    					longitude: 126.8491231, // -180.0 - +180.0
    					},
    				},
    				record: {
    					recordProgram : "arecord",  
    					device        : "plughw:1",
    				},
    				notifications: {
    					ASSISTANT_ACTIVATED: "HOTWORD_PAUSE",
    					ASSISTANT_DEACTIVATED: "HOTWORD_RESUME",
    				},
    				useWelcomeMessage: "brief today",
    				profiles: {
    					"default" : {
    						lang: "en-US"
    					}
    				},
    			}
    		},
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    

    Thanks in advance!

    Brew



  • @ForeverBrewing

    mine is using the same source… and works…

    {
          module: "newsfeed",
          disabled: false,
          position: "bottom_bar",
          config: {
    	ignoreOldItems:false,
            feeds: [
              {
                title: "New York Times",
                url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
              },        
            ],
            showSourceTitle: true,
            showPublishDate: true
          }
        },
    


  • @sdetweil
    I have tried re-editing your paste into my config.js. There were a couple of minor formatting changes, but ultimately the problem persists.

    Thanks for having a look though!



  • @ForeverBrewing ok, "Loading… " is the default message displayed until data comes in… then its replaced by the formatted data…

    so, open the developers window, ctrl-shift-i on the keyboard, select the tab labeled console, and scroll up to find any errors…

    many times one can filter the messages by the some part of the module name in this case 'news"



  • @sdetweil
    Hey Sam. I have looked through the dev window and cant find any errors, but it is clearly unhappy about something.

    Below is a sample of what i get as soon as I start the MM:

    Load script: modules/default/newsfeed//newsfeed.js
    module.js:476 Module registered: newsfeed
    loader.js:150 Bootstrapping module: newsfeed
    loader.js:155 Scripts loaded for: newsfeed
    loader.js:157 Styles loaded for: newsfeed
    loader.js:159 Translations loaded for: newsfeed
    newsfeed.js:61 Starting module: newsfeed
    newsfeed.js:370 newsfeed - received notification: ALL_MODULES_STARTED
    newsfeed.js:429 newsfeed - unknown notification, ignoring: ALL_MODULES_STARTED
    newsfeed.js:370 newsfeed - received notification: MODULE_DOM_CREATED
    newsfeed.js:429 newsfeed - unknown notification, ignoring: MODULE_DOM_CREATED
    newsfeed.js:370 newsfeed - received notification: DOM_OBJECTS_CREATED
    newsfeed.js:429 newsfeed - unknown notification, ignoring: DOM_OBJECTS_CREATED
    newsfeed.js:370 newsfeed - received notification: CLOCK_SECOND
    newsfeed.js:429 newsfeed - unknown notification, ignoring: CLOCK_SECOND
    newsfeed.js:370 newsfeed - received notification: CLOCK_SECOND
    newsfeed.js:429 newsfeed - unknown notification, ignoring: CLOCK_SECOND
    newsfeed.js:370 newsfeed - received notification: CURRENTWEATHER_DATA
    newsfeed.js:429 newsfeed - unknown notification, ignoring: CURRENTWEATHER_DATA
    newsfeed.js:370 newsfeed - received notification: CLOCK_SECOND
    newsfeed.js:429 newsfeed - unknown notification, ignoring: CLOCK_SECOND
    newsfeed.js:370 newsfeed - received notification: CLOCK_SECOND
    newsfeed.js:429 newsfeed - unknown notification, ignoring: CLOCK_SECOND
    newsfeed.js:370 newsfeed - received notification: CLOCK_MINUTE
    newsfeed.js:429 newsfeed - unknown notification, ignoring: CLOCK_MINUTE
    newsfeed.js:370 newsfeed - received notification: CLOCK_SECOND
    newsfeed.js:429 newsfeed - unknown notification, ignoring: CLOCK_SECOND
    newsfeed.js:370 newsfeed - received notification: CLOCK_SECOND
    newsfeed.js:429 newsfeed - unknown notification, ignoring: CLOCK_SECOND
    newsfeed.js:370

    etc etc.

    I have tried to click the link and see where in the code the error is, but I am WAAAAY out of my league. The fact is I have literally no idea what i’m looking at and am 100% relying on everybody else’s knowledge to manage anything vaguely resembling anything clever.

    Hope this helps?

    Brew



  • @ForeverBrewing said in MagicMirror Newsfeed continually “loading”...:

    The fact is I have literally no idea what i’m looking at

    its ok… we all learn over time…

    the system allows modules to talk to each other by sending ‘notification’ messages…

    most of what you see are the clock noisily telling others that time is ticking…

    but, I don’t see any messages about the feed setup…



  • @sdetweil
    Once I stop filtering for “news” I do see one error, but it relates the the weather module:

    newsfeed - unknown notification, ignoring: CLOCK_SECOND
    api.openweathermap.o…43aac34d08eb3e2f3:1 Failed to load resource: the server responded with a status of 401 (Unauthorized)
    weatherforecast.js:266 weatherforecast: Your AppID does not support long term forecasts. Switching to fallback endpoint.
    newsfeed.js:370 newsfeed - received notification: CLOCK_SECOND

    I don’t know if this is relevant in any way?



  • @ForeverBrewing said in MagicMirror Newsfeed continually “loading”...:

    Your AppID does not support long term forecasts.

    forecast is long term, the api gets picky…



  • @sdetweil Yeah, I guessed it was irrelevant to the newsfeed shenanigans



  • @ForeverBrewing i am trying to test here for info…


Log in to reply