MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Initial Setup Q's and Some Doc Feedback



  • Getting started, numerous issues and questions doing the initial setup.

    First, I want to say that the overall docs for installing and configuring this appear to be reasonably solid and generally well-maintained - kudos for that!

    With that said, there appear to be some gaps that I’m falling into.

    The doc I’m using to get started is this one: https://github.com/MichMich/MagicMirror
    I have an RPi3 with a 64G card. I am using the full Raspbian image and loaded it via NOOBS. After booting up and stepping through the few minimum steps that the device requires (including setting up WLAN and doing an OS update and then restart), I drop to a shell to begin the MM install and setup. For automatic installation, all I should have to issue (according to the docs) is

    bash -c "$(curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh)"
    

    While that works, there are a LOT of warnings about things potentially not working. So, I opted to update node.js according to the next two steps:

    curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -
    sudo apt install -y nodejs
    

    This clearly processes updates and “makes me feel better.” Was it a necessary step? Should this have been required given that I opted for the “automatic” install?

    Backing up just a bit, there appears to be no guidance in the install doc as to whether I should choose to allow the installer to set MM to autostart and/or whether I should disable the screensaver during the install process. I chose “N” and “Y” respectively.

    After the node.js updates and a restart, I moved on to the Configuration section and opted to follow this doc: https://github.com/MichMich/MagicMirror/wiki/Configuring-the-Raspberry-Pi

    The information in the OpenGL driver section are very confusing. It states that you shouldn’t need to modify the OpenGL driver, then goes on to tell you to edit a file whose location has changed (but the commands still point to the old location - you have to find the info in the notes that the file has been moved), tells you to add a line for

    dtoverlay=vc4-kms-v3d
    

    Which looks IDENTICAL to the new default (which is already in the file) as

    dtoverlay=vc4-fkms-v3d
    

    That is also referenced as an option later on in the doc, but there’s no commentary that I could find as to whether I should use one or the other for my specific hardware. Also, the file HAS the new default, but it’s in a RPi4 section. Again, very confusing here, and really don’t know what I should have opted for. I chose the full OpenGL and not the “fake” one.

    In the Screensaver section, the first portion is already present since I opted to let the installer disable the screensaver. The second portion, however (LightDM) is not only not present but there is no discussion of what this is. Is this actually a required piece? What does it do?

    The section for disabling WiFi Power Saving seems pretty broken, at least for my needs. The section about adding information for Pi3 (Jesse and below) will BREAK your setup if using a new release. If nothing else, I would say this entire doc would be immensely easier to follow if there were some direction provided for inspecting the /etc/os-release file to determine which build of Raspbian is being used along with some notes on which names were released in which order (so you know that buster is newer than Jesse, for example).

    For the VNC server section, it was quite simple for me to just “turn on” the SSH and VNC server options from the Options panel in the desktop on the RPi when doing initial setup. I also want to point out that doing it this way also requires that the security options on the server be changed from UNIX Password to VNC Password or at least some VNC clients won’t connect.

    If anyone has any thoughts on the pieces where I wasn’t sure what to do, I’d appreciate it. Thanks!



  • @ember1205 the installer you used is WAY downlevel… I have created a new one that will be released on the next update

    see
    https://forum.magicmirror.builders/topic/10171/anyone-want-to-try-updated-installer

    if u want to run it now, then rename the MagicMirror folder out of the way and use the command
    provided in the linked topic
    (note there is also a new script for updates, and a new script to fix PM2 should you change your mind or have trouble)… all added to the next release

    it solves most of the issues you mentioned…

    except for warnings… which were added to the npm install processes, and we have no control.
    they ARE Warnings… so unless u intend your mirror to be accessed from over the internet, i think most are not worth chasing down… (the updates to fix the ‘vulnerabilities’ MAY/have/will at some time, mess things up and the mirror won’t run. (due to somebody elses code being broken)…

    notice on the kms driver the F letter
    dtoverlay=vc4-fkms-v3d
    means use the FAKE driver, not real… it MAY work, for portrait rotated displays it seems to have problems (search the forum)



  • @ember1205 said in Initial Setup Q’s and Some Doc Feedback:

    Backing up just a bit, there appears to be no guidance in the install doc as to whether I should choose to allow the installer to set MM to autostart and/or whether I should disable the screensaver during the install process. I chose “N” and “Y” respectively.

    that is all really choice on your installation and and usage planning…

    i don’t want to touch the mirror… if it reboots cause of power outage, etc, I want it to logon, and start mirror, and never screen lock…

    so, set OS to auto logon (manual step)
    use pm2 to autostart
    and turn off screensaver



  • @sdetweil

    Thanks… Good updates. I will definitely look through your updated installer.

    With regard to the warnings - I understand what you’re saying, but my concerns were driven more by the warnings that said “this might not even work.” I realize that they may be very specific to certain aspects, but given that isn’t indicated specifically, it raised up my alert level.

    On the fake versus real driver piece, I did notice the “f” to indicate the fake driver. With zero experience with this piece, and having no background that there IS a fake driver or that it’s now default, my eyes told me that the name for the fake driver was actually the name for the real one at first [two] glance[s]. It wasn’t until I reached the latter part talking about the fake driver that I realized it was a different name and changed it.

    I’m not using portrait mode as I want this to be a “Magic Photo Frame” and display pictures (many of which are in landscape format), so it seems that I might be able to use either.



  • @sdetweil said in Initial Setup Q’s and Some Doc Feedback:

    @ember1205 said in Initial Setup Q’s and Some Doc Feedback:

    Backing up just a bit, there appears to be no guidance in the install doc as to whether I should choose to allow the installer to set MM to autostart and/or whether I should disable the screensaver during the install process. I chose “N” and “Y” respectively.

    that is all really choice on your installation and and usage planning…

    i don’t want to touch the mirror… if it reboots cause of power outage, etc, I want it to logon, and start mirror, and never screen lock…

    so, set OS to auto logon (manual step)
    use pm2 to autostart
    and turn off screensaver

    Yes. Those were all done. But, the screensaver disable was done during the install and it appears to not have modified the same files as the manual changes show.



  • @ember1205 i didn’t set the OpenGL driver… not worth the hassle. the driver is REALLY useful for algorithmic objects, rotating in 3d… nothing we do on the mirror



  • @ember1205 said in Initial Setup Q’s and Some Doc Feedback:

    Yes. Those were all done. But, the screensaver disable was done during the install and it appears to not have modified the same files as the manual changes show.

    hm… i didn’t update the doc for manual install for my new installer… there are just too many places with different solutions…

    I embodied all that I know about and generalized to attempt to cover more as time goes on.



  • @ember1205 There are three locations where the screensaver might be starting from, and only one of them is actually run (I believe the first found in this order):

    /home/pi/.config/lxsession/LXDE-pi/autostart
    /etc/xdg/lxsession/LXDE-pi/autostart
    /etc/xdg/lxsession/LXDE/autostart

    Raspbian recently changed to not having the first one, so the second is now the preferred method.



  • @dsegel thx… already in the updated installer and the screensaver fixer scripts



  • @dsegel said in Initial Setup Q’s and Some Doc Feedback:

    @ember1205 There are three locations where the screensaver might be starting from, and only one of them is actually run (I believe the first found in this order):

    /home/pi/.config/lxsession/LXDE-pi/autostart
    /etc/xdg/lxsession/LXDE-pi/autostart
    /etc/xdg/lxsession/LXDE/autostart

    Raspbian recently changed to not having the first one, so the second is now the preferred method.

    So… None of that works. The ONLY way I could get the screensaver to shut off was to do:

    sudo apt install xscreensaver
    

    And then run the Screensaver Preferences setup and set it to disabled. Anything else I tried ultimately allowed the screen to go blank (black) after about 15 minutes.


Log in to reply