Electron not found

  • First magic mirror so bear with me. After having much trouble with the automatic installer

    bash -c "$(curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh)"

    I switched to the manual install method found on the MM2 git repo. During install I get the electron error stating there’s no version for arm6l. To remedy I ran

    npm install --arch=armv7l electron@2.0.0

    Which successfully installed electron. I then reran npm install inside the ~/MagicMirror folder. I got the Magic mirror installed successfully message and no errors, but MagicMirror will not run after npm start.
    If I try sh run-start.sh I get run-start.sh: 7: run-start.sh: electron: not found

    Any help would be appreciated, seems no tutorial I’ve found handles the electron not supporting armv6l device error.

    Device: Raspi 3 B+
    OS: Raspbian Stretch 2019-04-08
    Node: 10.18.0
    npm: 6.13.4

  • @voxum armv6 is falling out of favor…

    rename the MagicMirror folder out of the way, or delete it

    use my install script…
    see https://forum.magicmirror.builders/topic/10171/anyone-want-to-try-updated-installer
    (it will be in the next release)

    it will setup for serveronly and launch chrome to be the browser instead of electron

  • @sdetweil
    Worked like a charm. Now to mess around with some additional features. Thanks so much!