MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

How I got my Magic Mirror working on a Raspberry Pi 0 (zero)



  • I used the image that was posted a few comments back. I can NOT for the life of me get the wireless to connect. I have followed every guide I can find and it will not connect. I have tried DHCP and static. I’m out of ideas.



  • @justindp2006 Had the same issue. Couldnt find the fix anywhere



  • @justindp2006 so you followed the guide and entered you ssid and password?
    You could try the terminal command

    sudo raspi-config
    

    And set up wifi via the on screen menu.

    Failing that u could set up a wpa supplicant file and insert it in your sd card
    https://howchoo.com/g/ndy1zte2yjn/how-to-set-up-wifi-on-your-raspberry-pi-without-ethernet

    Hope this helps



  • @greenwaydev sorry that post was kinda screwed as I made it on my phone the command was

    sudo raspi-config
    


  • @Mikgabo said in How I got my Magic Mirror working on a Raspberry Pi 0 (zero):

    wed as I made it o

    I understood 🙂 I tried that earlier and again and there is no networking options under it?





  • Tried. Think it’s time to toss in the towel. Hours lost to this project. It would be one thing if I was new to all of this or ignorant to programming or pis in general. I just don’t understand and there are no clues. Thanks for the replies.



  • OK, so I haven’t confirmed it on this package but was having the SAME EXACT issue with an octoprint setup for my printer. Anyhow I ran sudo iwlist wlan0 scan and it sees my network. Here is the kicker though. My network shows up like "MyNetworkHere ". There is a space between MyNetworkHere and the ". I added the space, saved and rebooted and it immediately connected. Hope this helps someone.



  • I can’t get Magic Mirror to launch. Is this a problem with the scripts?

    0_1525534860772_fullsizeinput_40e.jpeg



  • “How I didn’t got my Magic Mirror working on a Raspberry Pi 0 (zero) w”

    tl;dr: My findings are that latest MM doesn't work on ARM 6 (Pi 0/1).
    

    Hi all, I’m a Pi noob and I wanted to use my RPi 0w to put the magic in my mirror. I followed this guide but despite everything ‘apparently’ working, I only ever got a blank screen.

    • I followed this guide line by line (keeping same, out of date versions) I got warnings when installing MM but it installed however when Midori launched I only got a blank screen.
    • I followed this guide using Jessie lite but the latest l6 node version. Blank screen.
    • I tried on Stretch Lite with the latest l6 node… same problem. I even tried numerous browsers on Stretch as I read Midori had issues on Stretch. Blank screen.
    • I tested all the above by launching Midori with Google and that worked each time, the blank screen was only with MM.

    I used SebTota’s image (link p9) and also had issues connecting to the internet. After bit of investigation I realised for me this wasn’t a WiFi issue (as others reported) but a Gateway issue even though it was set correctly in /etc/dhcpcd.conf

    For those struggling with internet access, and if you can ping the LAN but not the internet, try this:

    $ route -n
    

    If the Gateway entry is 0.0.0.0 you have the same issue I did, correct it with:

    $ sudo route add default gw 10.0.0.1
    

    *(change the IP to your own router IP) then you should be able to reach the outside world.

    This worked!!! However… SebTota’s image is now old and as soon as I connected to the internet, MM complains it’s out of date. As soon as you update MM, I got the same blank screen issue.

    After hours of investigating and trying and trying again, I can only surmise that the issue is with the latest MM build
    and that it’s just not designed for ARM6 architecture. It does however work just fine on my PRi 3B+ so there is definitely not an issue with MM!! It’s just a shame I can’t use the ultra small 0w to drive the mirror.

    I’m no expert and this could be just me but I just thought I might share my findings in case it helps anyone else.