MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

erro MMM-HASS



  • I have the following error when trying to use the MMM-HASS module. MM loads, but keeps all modules with loading status.

    pi@raspberrypi:~/MagicMirror $ npm start
    
    > magicmirror@2.10.0 start /home/pi/MagicMirror
    > ./run-start.sh
    
    [21:04:03.127] [LOG] Starting MagicMirror: v2.10.0
    [21:04:03.163] [LOG] Loading config ...
    [21:04:03.185] [LOG] Loading module helpers ...
    [21:04:03.191] [LOG] No helper found for module: alert.
    [21:04:03.401] [LOG] Initializing new module helper ...
    [21:04:03.405] [LOG] Module helper loaded: updatenotification
    [21:04:03.408] [LOG] No helper found for module: clock.
    [21:04:04.630] [LOG] Initializing new module helper ...
    [21:04:04.633] [LOG] Module helper loaded: MMM-Screencast
    [21:04:06.010] [LOG] Initializing new module helper ...
    [21:04:06.013] [LOG] Module helper loaded: calendar
    [21:04:06.016] [LOG] No helper found for module: compliments.
    [21:04:07.345] [LOG] Initializing new module helper ...
    [21:04:07.347] [LOG] Module helper loaded: MMM-DarkSkyForecast
    [21:04:07.457] [LOG] Initializing new module helper ...
    [21:04:07.460] [LOG] Module helper loaded: newsfeed
    [21:04:07.548] [LOG] Initializing new module helper ...
    [21:04:07.553] [LOG] Module helper loaded: MMM-HASS
    [21:04:07.557] [LOG] All module helpers loaded.
    [21:04:07.563] [LOG] Starting server on port 8080 ...
    [21:04:07.688] [LOG] Server started ...
    [21:04:07.695] [LOG] Connecting socket for: updatenotification
    [21:04:07.703] [LOG] Connecting socket for: MMM-Screencast
    [21:04:07.710] [LOG] Connecting socket for: calendar
    [21:04:07.716] [LOG] Starting node helper for: calendar
    [21:04:07.721] [LOG] Connecting socket for: MMM-DarkSkyForecast
    [21:04:07.724] [LOG] ====================== Starting node_helper for module [MMM-DarkSkyForecast]
    [21:04:07.729] [LOG] Connecting socket for: newsfeed
    [21:04:07.734] [LOG] Starting module: newsfeed
    [21:04:07.740] [LOG] Connecting socket for: MMM-HASS
    [21:04:07.745] [LOG] Sockets connected & modules started ...
    [21:04:07.748] [LOG]
    Ready to go! Please point your browser to: http://localhost:8080
    Starting chromium browser now, have patience, it takes a minute
     --disable-quic --enable-tcp-fast-open --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so --ppapi-flash-args=enable_stagevideo_auto=0 --ppapi-flash-version=
    events.js:174
          throw er; // Unhandled 'error' event
          ^
    
    Error [ERR_STREAM_DESTROYED]: Cannot call write after a stream was destroyed
        at doWrite (_stream_writable.js:411:19)
        at writeOrBuffer (_stream_writable.js:399:5)
        at Socket.Writable.write (_stream_writable.js:299:11)
        at Console.con.(anonymous function) [as log] (/home/pi/MagicMirror/node_modules/console-stamp/main.js:150:46)
        at process. (/home/pi/MagicMirror/js/app.js:40:10)
        at process.emit (events.js:198:13)
        at process._fatalException (internal/bootstrap/node.js:497:27)
    


  • @iorifly get it this way

    cd ~/MagicMirror
    curl -sL https://raw.githubusercontent.com/sdetweil/MagicMirror_scripts/master/run-start.sh >run-start.sh
    


  • @iorifly I will look at this tomorrow. Send me your config via text message



  • @sdetweil

    Much! Thanks so much for helping me out! I do not know what else to do. I will send everything here to you.
    by message is not going.

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     *
     * For more information how you can configurate this file
     * See https://github.com/MichMich/MagicMirror#configuration
     *
     */
    
    var config = {
        address: "localhost", // Address to listen on, can be:
                              // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
                              // - another specific IPv4/6 to listen on a specific interface
                              // - "", "0.0.0.0", "::" to listen on any interface
                              // Default, when address config is left out, is "localhost"
        port: 8080,
        ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
                                                               // or add a specific IPv4 of 192.168.1.5 :
                                                               // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
                                                               // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
                                                               // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
        language: "pt",
        timeFormat: 24,
        units: "metric",
        // serverOnly:  true/false/"local" ,
                     // local for armv6l processors, default 
                     //   starts serveronly and then starts chrome browser
                     // false, default for all  NON-armv6l devices
                     // true, force serveronly mode, because you want to.. no UI on this device
        
        modules: [
            {
                module: "alert",
            },
            {
                module: "updatenotification",
                position: "top_bar"
            },
            {
                module: "clock",
                position: "top_left"
            },    
                   {
                module: "calendar",
                header: "Feriados",
                position: "top_left",
                config: {
                    calendars: [
                        {
                            symbol: "calendar-check",
                            url: "https://www.calendarlabs.com/ical-calendar/ics/37/Brazil_Holidays.ics"                    }
                    ]
                }
            },
            {
                module: "compliments",
                position: "lower_third"
            },
            
            {
                           module: "MMM-DarkSkyForecast",
                           header: "Tempo em Duque de Caxias",
                           position: "top_right",
                           classes: "default everyone",
                           disabled: false,
                           config: {
                             apikey: "****",
                             latitude: "-22.787860",
                             longitude: "-43.303140",      
                             iconset: "4c",
                             units: "si",
                             concise: false,
                             forecastLayout: "table"
                          }
                    },
            
                    {
                    module: 'MMM-Screencast',
                    position: 'middle_center', // This position is for a hidden <div> and not the screencast window
                    config: {
                        position: 'center',
                        height: 300,
                        width: 500,
                    }
                   },
            
            
            
            {
                        module: "newsfeed",
                        position: "bottom_bar",
                        config: {
                            feeds: [
                                {
                                    title: "Noticias R7",
                                    url: "https://noticias.r7.com/rio-de-janeiro/feed.xml"
                                }
                            ],
                            showSourceTitle: true,
                            showPublishDate: true,
                            broadcastNewsFeeds: true,
                            broadcastNewsUpdates: true
                        }
                    },
                            {
                    module: "MMM-HASS",
                    position: "middle_center",
                    config: {
                            host: "192.168.1.158",
                            port: "8123",
                            apipassword: "jeure3027",
                            hassiotoken: false,
                            https: false,
                            devices: [
                            { deviceLabel: "Exterior",
                                    deviceReadings: [
                                    { sensor: "sensor.disk_free", icon: "wi wi-thermometer", suffix: "%"}
                                    
                                    ]
                              }
                            
                                   ]
                            }       
            
                 },
            
                ]
            
            };
            
            /*************** DO NOT EDIT THE LINE BELOW ***************/
            if (typeof module !== "undefined") {module.exports = config;}
            
    ```</div>


  • @iorifly I can recreate the failure, but if I remove the MMM-HASS module, it doesn’t fail…

    debugging, but not sure yet…
    if I run serverOnly mode and and access the system from a browser on another system, that browser doesn’t report any unexpected errors…

    pi0, raspian jessie,
    node -v v10.17.0
    npm -v 6.11.3

    MM 2.10.0

    chromium-browser --version
    Chromium 56.0.2924.84 Built on Ubuntu 14.04, running on Raspbian 8.0



  • @sdetweil said in erro MMM-HASS:

    pi0, raspian jessie,

    When I remove HASS it also works.

    But I did not understand. You think there’s no way. Still debugging?



  • @iorifly yes, not home now. Will try to spend some time tomorrow



  • I look forward to something tomorrow. Thank you for not leaving me!



  • My exit when I request browser version

    pi@raspberrypi:~/MagicMirror $ chromium-browser --version
     --disable-quic --enable-tcp-fast-open --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so --ppapi-flash-args=enable_stagevideo_auto=0 --ppapi-flash-version=
    Chromium 74.0.3729.157 Built on Raspbian , running on Raspbian 10
    


  • @iorifly

    ok, i have found the problem… all my fault

    edit ~/MagicMirror/run-start.sh

    	#exec 3< &-           #  edit this line and comment out with leading #
    	tee < &3 &             #  add this line  after the line above, no space between < and &3, forum is real trouble with < 
    


  • guy!!

    I’m not home at the moment BUT HOW HAPPY I am. Will I be able to use the module? I will return as soon as possible to you. THANK YOU FOR HELPING ME AND NOT ABANDONING THE BOAT.


Log in to reply