MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Sometimes Black Screen after upgrade to 2.11.0



  • Hi!
    I’m very new to MM2 and had the MM2 running for 2-3 weeks without problems.
    But after the update to 2.11.0 the MM2 starts sometimes with black screen.
    Here ist the output of the logfiles:

    /home/pi/.pm2/logs/mm-out.log

    > magicmirror@2.11.0 start /home/pi/MagicMirror
    > DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js
    
    [2020-04-10 07:06:04.275] [LOG]    Starting MagicMirror: v2.11.0
    [2020-04-10 07:06:04.322] [LOG]    Loading config ...
    [2020-04-10 07:06:04.336] [LOG]    Loading module helpers ...
    [2020-04-10 07:06:04.340] [LOG]    No helper found for module: alert.
    [2020-04-10 07:06:04.460] [LOG]    Initializing new module helper ...
    [2020-04-10 07:06:04.461] [LOG]    Module helper loaded: updatenotification
    [2020-04-10 07:06:04.464] [LOG]    No helper found for module: clock.
    [2020-04-10 07:06:05.408] [LOG]    Initializing new module helper ...
    [2020-04-10 07:06:05.409] [LOG]    Module helper loaded: MMM-MyCalendar
    [2020-04-10 07:06:06.272] [LOG]    Initializing new module helper ...
    [2020-04-10 07:06:06.273] [LOG]    Module helper loaded: MMM-DWD-WarnWeather
    [2020-04-10 07:06:07.295] [LOG]    Initializing new module helper ...
    [2020-04-10 07:06:07.300] [LOG]    Module helper loaded: MMM-DarkSkyForecast
    [2020-04-10 07:06:07.717] [LOG]    Initializing new module helper ...
    [2020-04-10 07:06:07.718] [LOG]    Module helper loaded: MMM-CalendarExt2
    [2020-04-10 07:06:07.859] [LOG]    Initializing new module helper ...
    [2020-04-10 07:06:07.860] [LOG]    Module helper loaded: MMM-Bring
    [2020-04-10 07:06:07.942] [LOG]    Initializing new module helper ...
    [2020-04-10 07:06:07.943] [LOG]    Module helper loaded: newsfeed
    [2020-04-10 07:06:07.943] [LOG]    All module helpers loaded.
    [2020-04-10 07:06:08.257] [LOG]    Starting server on port 8080 ... 
    [2020-04-10 07:06:08.286] [LOG]    Server started ...
    [2020-04-10 07:06:08.287] [LOG]    Connecting socket for: updatenotification
    [2020-04-10 07:06:08.289] [LOG]    Connecting socket for: MMM-MyCalendar
    [2020-04-10 07:06:08.290] [LOG]    Starting node helper for: MMM-MyCalendar
    [2020-04-10 07:06:08.291] [LOG]    Connecting socket for: MMM-DWD-WarnWeather
    [2020-04-10 07:06:08.292] [LOG]    MMM-DWD-WarnWeather helper started...
    [2020-04-10 07:06:08.293] [LOG]    Connecting socket for: MMM-DarkSkyForecast
    [2020-04-10 07:06:08.294] [LOG]    ====================== Starting node_helper for module [MMM-DarkSkyForecast]
    [2020-04-10 07:06:08.295] [LOG]    Connecting socket for: MMM-CalendarExt2
    [2020-04-10 07:06:08.297] [LOG]    Connecting socket for: MMM-Bring
    [2020-04-10 07:06:08.298] [LOG]    Connecting socket for: newsfeed
    [2020-04-10 07:06:08.299] [LOG]    Starting module: newsfeed
    [2020-04-10 07:06:08.300] [LOG]    Sockets connected & modules started ...
    [2020-04-10 07:06:08.833] [LOG]    Launching application.
    

    /home/pi/.npm/_logs/2020-04-09T06_07_27_758Z-debug.log

    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
    2 info using npm@6.13.4
    3 info using node@v10.19.0
    4 verbose run-script [ 'prestart', 'start', 'poststart' ]
    5 info lifecycle magicmirror@2.11.0~prestart: magicmirror@2.11.0
    6 info lifecycle magicmirror@2.11.0~start: magicmirror@2.11.0
    7 verbose lifecycle magicmirror@2.11.0~start: unsafe-perm in lifecycle true
    8 verbose lifecycle magicmirror@2.11.0~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    9 verbose lifecycle magicmirror@2.11.0~start: CWD: /home/pi/MagicMirror
    10 silly lifecycle magicmirror@2.11.0~start: Args: [ '-c',
    10 silly lifecycle   'DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js' ]
    11 silly lifecycle magicmirror@2.11.0~start: Returned: code: 1  signal: null
    12 info lifecycle magicmirror@2.11.0~start: Failed to exec start script
    13 verbose stack Error: magicmirror@2.11.0 start: `DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js`
    13 verbose stack Exit status 1
    13 verbose stack     at EventEmitter. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
    13 verbose stack     at EventEmitter.emit (events.js:198:13)
    13 verbose stack     at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
    13 verbose stack     at ChildProcess.emit (events.js:198:13)
    13 verbose stack     at maybeClose (internal/child_process.js:982:16)
    13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
    14 verbose pkgid magicmirror@2.11.0
    15 verbose cwd /home/pi/MagicMirror
    16 verbose Linux 4.19.97-v7+
    17 verbose argv "/usr/bin/node" "/usr/bin/npm" "start"
    18 verbose node v10.19.0
    19 verbose npm  v6.13.4
    20 error code ELIFECYCLE
    21 error errno 1
    22 error magicmirror@2.11.0 start: `DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js`
    22 error Exit status 1
    23 error Failed at the magicmirror@2.11.0 start script.
    23 error This is probably not a problem with npm. There is likely additional logging output above.
    24 verbose exit [ 1, true ]
    

    When I try to start the MM2 2-3 times the black screen goes away and the MM2 is running normal.

    I don’t know much about npm so I’m totally lost.
    Maybe someone have an idea what I can try to solve this problem.



  • @M_M said in Sometimes Black Screen after upgrade to 2.11.0:

    Failed to exec start script

    does it make a difference whether the pm2 start is done by boot or from a terminal window after logon

    did you use my automated installer?

    if so do this

    pm2 stop 0
    pm2 delete 0
    pm2 start ~/MagicMirror/installers/pm2_MagicMirror.json
    if doing this over ssh or vnc, skip next step 
        alt-spacebar, n to minimze MagicMirror to get back to terminal window
    pm2 save
    

    then redo your start testing



  • Hi Sam!
    Thank you for your support!

    Unfortunately all my last tries were not successful.
    Even your upgrade scripts with apply and force…

    So I decided to start from scratch.
    I removed/purged nodejs completly from the system and installed all new.

    Now it is running as it should.

    Don’t know what it was and I hope that this will not come back by the next upgrade…


Log in to reply