MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-AssistantMk2 with Hotword not picking up anything.



  • I initially tried to use this module when I first set up my mirror, but moved over to gauravsacc’s MMM-GoogleAssistant, where I managed to get GA working in the terminal but not in the mirror. There seems to be more flexibility with this module so I have moved back and decided to face what I’ve done (or not done). Essentially, I’m fairly certain my configuration is wrong but I’m unsure how to correct it. When I start up MagicMirror the logs say:

    [AMK2] MMM-AssistantMk2 Version: 3.2.2
    [AMK2] AssistantMk2 is initialized.
    [HOTWORD] begins.
    [HOTWORD] Detector starts listening.

    However when I say one of the configured Hotword nothing happens. The monitor for my Mirror also doesn’t show the google assistant logo which I believe should be showing up.

    My config:

              {
    
                       module: "MMM-Hotword",
    
                       position: "top_right",
    
                       config: {
    
                               chimeOnFinsih: null,
    
                               mic: {
    
                                       recordProgram : "arecord",
    
                                       device        : "plughw:1"
    
                               },
    
                               models: [
    
                                       {
    
                                               hotwords : "computer",
    
                                               file : "computer.umdl",
    
                                               sensitivity : 0.5,
    
                                       },
    
                                       {
    
                                               hotwords : "smart_mirror",
    
                                               file : "smart_mirror.umdl",
    
                                               sensitivity: "0.5",
    
                                       },
    
                               ],
    
                               commands: {
    
                                       "computer": {
    
                                               notificationsExec: {
    
                                                       notification: "TEST",
    
                                               },
    
                                               restart:false
    
                                       }
    
                               }
    
                       }
    
               },
    
               {
    
                       module: "MMM-AssistantMk2",
    
                       position: "top_right",
    
                       config: {
    
                               deviceLocation: {
    
                                       coordinates: { // set the latitude and longitude of the device to get localized information like weather or time. (ref. mygeoposition.com)
    
                                               latitude: xxxxxxx, // -90.0 - +90.0
    
                                               longitude: xxxxxxx, // -180.0 - +180.0
    
                                       },
    
                               },
    
                               record: {
    
                                       recordProgram : "arecord",
    
                                       device        : "plughw:1",
    
                               },
    
                               notifications: {
    
                                       ASSISTANT_ACTIVATED: "HOTWORD_PAUSE",
    
                                       ASSISTANT_DEACTIVATED: "HOTWORD_RESUME",
    
                               },
    
                               useWelcomeMessage: "brief today",
    
                               profiles: {
    
                                       "default" : {
    
                                               lang: "en-UK"
    
                                       }
    
                               },
    
                       }
    

    @Bugsounet any clue (sorry this took a while to get together, I was re-familiarising myself with the module)

    Thanks


  • Module Developer

    Hummm,

    where do you find this weird configuration?



  • Haha, that bad is it?

    It’s kinda become a mess of different configs from different places whilst I was trying to troubleshoot last time I was trying to use it.
    As far as I can tell the config for Hotword is essentially the same as the sample in the documentation though?


  • Module Developer

    I think its better for you to restart with MMM-AssistantMk2 wiki

    MMM-Hotword is designed for complexe configuration with multiple keyword for execute notification to other module with some keyword installed

    if MMM-Hotword is too complex for you use MMM-Snowboy



  • Okay, I’ll give that a go. I didn’t realise that you could just use snowboy - although when I tried to set it up before the website wouldn’t allow me to record (obviously not your problem, probably either theirs or mine)

    Cheers



  • @Bugsounet So I’ve got it working to a much better extent (it actually shows up on screen which is useful). Do you actually need to use Snowboy or Hotword at all? Or can you just use ‘Ok Google’, if so that’s not working so it could be my mic.



  • @reubenvickers

    When you install does it pass Play/Mic test…?

    And you have copied mic config into Assistant config.


  • Module Developer

    @reubenvickers : can’t use Ok Google, it’s not a real google device, it’s just an Google SDK project
    If you want to use Ok Google keyword, it’s possible but it’s complex



  • @Bugsounet finally got it working using Snowboy. Thanks for all your help and sorry for my ineptitude.


  • Module Developer

    it doesn’t matter, just read the wiki,
    I think I did something complete 🙂


Log in to reply