MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

parent error



  • I am not sure how to solve this error? git pull & npm install are updated. Running docker image.

    {"log":"[2020-06-12 23:23:18.815] [ERROR]  TypeError: Cannot read property 'parent' of null\r\n","stream":"stdout","time":"2020-06-13T04:23:18.817764599Z"}
    {"log":"    at Function.exports.update (/opt/magic_mirror/modules/node_modules/cheerio/lib/parse.js:55:26)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.819454137Z"}
    {"log":"    at module.exports (/opt/magic_mirror/modules/node_modules/cheerio/lib/parse.js:17:11)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.821140799Z"}
    {"log":"    at Function.exports.load (/opt/magic_mirror/modules/node_modules/cheerio/lib/static.js:22:14)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.822416037Z"}
    {"log":"    at parseRottenTomatoesHTML (/opt/magic_mirror/modules/node_modules/rt-scraper/index.js:41:42)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.823976662Z"}
    {"log":"    at Request._callback (/opt/magic_mirror/modules/node_modules/rt-scraper/index.js:97:34)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.826628649Z"}
    {"log":"    at Request.self.callback (/opt/magic_mirror/modules/node_modules/request/request.js:185:22)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.830505399Z"}
    {"log":"    at Request.emit (events.js:182:13)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.832477212Z"}
    {"log":"    at Request.\u003canonymous\u003e (/opt/magic_mirror/modules/node_modules/request/request.js:1161:10)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.833481824Z"}
    {"log":"    at Request.emit (events.js:182:13)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.834967487Z"}
    {"log":"    at IncomingMessage.\u003canonymous\u003e (/opt/magic_mirror/modules/node_modules/request/request.js:1083:12)\r\n","stream":"stdout","time":"2020-06-13T04:23:18.836340412Z"}
    {"log":"[2020-06-12 23:23:18.819] [LOG]    MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?\r\n","stream":"stdout","time":"2020-06-13T04:23:18.839240249Z"}
    {"log":"[2020-06-12 23:23:18.820] [LOG]    If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues\r\n","stream":"stdout","time":"2020-06-13T04:23:18.841228887Z"}
    


  • @jsmith432 what did you update? MagicMirror or a module?

    if MagicMirror, you ALSO need to check every module you installed, if it has a package.json file, you ALSO need to run npm install in that folder…

    for future MM upgrades, use the upgrade script from here https://github.com/sdetweil/MagicMirror_scripts

    its a two part process

    • run the script once (in test mode) to test upgrade and see if there will be any issues, files u might need to save
    • then run it again (in apply mode) to actually DO the upgrade install, and it will run thru all your enabled modules and do the npm install for them too…


  • @sdetweil Thanks for the response. I haven’t updated it for a while but when I do I always use git pull & npm install. I am not sure which module if any is causing this issue. I just noticed that this error was on the log. When updating modules I do the same git pull & npm install. I did on all modules and no updates were found.

    Should I run this script even if I am using MM in docker?



  • @jsmith432 sorry, the script doesn’t know how to update the docker container



  • @jsmith432 >I always use git pull & npm install.

    yes, understand. however there are times when the dependencies for MM change, which requires that all modules with dependencies need to update as well… 2.11 clearly calls out that there were dependency changes.

    I would guess from the stacktrace, its a movie module

    parseRottenTomatoesHTML in rt-scraper library
    at parseRottenTomatoesHTML (/opt/magic_mirror/modules/node_modules/rt-scraper/index.js



  • Thanks. That module don’t have a package.json and is probably using an old version of some kind of dependency then. I will remove the module completely as it has not been working anyway.


Log in to reply